0

I used to be able to copy and paste the .desktop files from use/share/applications to my desktop for shortcuts. When I first upgraded to 19.04, I selected the allow launching option on the right click context menu and they worked fine.

However, on one of the most recent updates, my shortcuts got deleted. When trying to add them and selecting allow launching, the shortcut will work but the icon will not change to the correct application and if I log out and back in again, the .desktop files are back to being opened in my text editor.

Is it possible to add .desktop files to the desktop and have them permanently launch-able again with the correct icons displaying as they used to before? ls -al ~/.local/share/gnome-shell/extensions gives me:

total 20 
drwxr-xr-x 5 user user 4096 Apr 18 12:33 . 
drwx------ 3 user user 4096 Jun 25 00:46 .. 
drwxrwxr-x 3 user user 4096 Apr 12 12:14 customcorner@eccheng.gitlab.com 
drwxrwxr-x 4 user user 4096 Apr 18 12:32 custom-hot-corners@janrunx.gmail.com 
drwxrwxr-x 5 user user 4096 Apr 18 12:33 dash-to-panel@jderose9.github.com
  • This is a problem in 19.04. To test for it, create a new folder on the Desktop called "Work in Progress", using the Files app, move your .desktop file into the new folder, and see if it works from there. I'll explain more later, if that works for you. – heynnema Jun 25 '19 at 2:17
  • @heynnema nope didn't work – NiallMitch14 Jun 25 '19 at 10:32
  • Lets eliminate two other things... log into another user account (create one if you have to) and see if the problem occurs there. Edit your question and show me ls -al ~/.local/share/gnome-shell/extensions. – heynnema Jun 25 '19 at 14:09
  • @heynnema So I've added the result of ls -al ~/.local/share/gnome-shell/extensionsI also added another user and tried to add a shortcut to desktop. When selecting allow launching, it worked perfectly. So I must have something installed or enabled on my default account – NiallMitch14 Jun 26 '19 at 14:11
  • Go to extensions.gnome.org/local and disable the three extensions, restart GNOME Shell (alt-F2, r, enter), and retest. If that doesn't fix the problem, let me know, and I'll put together an answer to help you troubleshoot. – heynnema Jun 26 '19 at 14:24
1

Logging into another user account shows us that everything works as expected. That means that something in your original user account is causing the problem.

Troubleshooting involves trying to determine what's causing your problem, and this may take some time/effort. But, I'll try an give you a start with an area where common problems occur.

Common problem areas can be the ~/.local folder, and ~/.config folder, and the ~/.cache folder. We rename these folders, only one at a time, log out, log back in, and see if the problem has gone away. Here's a note... most of these folders will get recreated when you log back in.

I'll use the ~/.config folder as an example, as this is the most difficult to do. Rename this folder to ~/.config.HOLD. Log out. Log back in. Retest for the problem. If the problem is resolved, then there's something in the ~/.config.HOLD folder that caused your problem. Now you have to restore files from the ~/.config.HOLD folder, back into the newly created ~/.config folder. You do this by dragging files/folders from ~/.config.HOLD back into ~/.config, but NOT REPLACING any existing files/folders that are already in the new ~/.config folder. (This way you'll be able to keep some/all of your application preferences). Then log out, log in, retest.

The same technique is used for the ~/.local folder, or any other files/folders in your home directory, excluding the major folders like Documents, Music, Pictures, etc.

Pay close attention to what you're doing, 'cause if you aren't careful, you can make it difficult to log back into your account. I'd leave the bash and profile and authority files alone.

Update #1:

If you decide that one of the .HOLD folders did not resolve the problem, to return to the previous configuration, you have to manipulate the new folders and the .HOLD folders this way... using .config as an example... move the new .config folder to ~/Desktop/config.NEW, rename .config.HOLD to .config, log out, log in, delete ~/Desktop/config.NEW.

| improve this answer | |
  • Fixed it! The problem was the ~/.local folder. Thanks! – NiallMitch14 Jun 26 '19 at 15:03
  • @NiallMitch14 that was quick! Glad it's working. – heynnema Jun 26 '19 at 15:04
  • 1
    @NiallMitch14 remember to finish moving files back into the new ~/.local folder, as per my instructions. – heynnema Jun 26 '19 at 15:15
  • This is terrible advice to go messing around with making copies of these folders. E.g. suppose you go through this and then decide that the change to ~/.config.HOLD didn't fix things. Moving the HOLD version back to ~/.config and then logging out will cause you to permanently lose your original configuration as (presumably) the in-memory config is rewritten to ~/.config upon logout. Just happened to me :( – EoghanM Aug 11 '19 at 13:39
  • @EoghanM You didn't follow my instructions. In your case, you should have moved the new .config folder to ~/Desktop/config.NEW, renamed .config.HOLD to .config, logged out, log in, delete ~/Desktop/config.NEW. – heynnema Aug 11 '19 at 13:47
0

Your problem description makes me suspect that your file with dconf settings has been corrupted somehow. To find out, you may want to try this:

cd ~/.config/dconf
mv user user.bak

Then relogin and check if it behaves better.

| improve this answer | |
  • Still behaves the same way – NiallMitch14 Jun 25 '19 at 10:32
0

I had the same issue after upgrading to Ubuntu 19.10 from Ubuntu 19.04. The key problem was that the "Allow launching" menu option was not available after right clicking on the icon on the desktop.

After a lot of searching I found this link http://ubuntuhandbook.org/index.php/2019/10/send-app-shortcut-icons-desktop-in-ubuntu-19-10/.

Basically you just need to open Files and copy your .desktop file to your Desktop folder. You cannot copy it directly by dragging onto your desktop. Then minimise files and on your Desktop right click on your copied .desktop icon and you should see the "Allow Launching" option. Once you click on this everything works (or at least it did for me).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.