3

So I just got a new laptop (Asus VivoBook S15) that came with a preinstalled Win10 on the only hard drive. I'm trying to do a clean Ubuntu install to replace Windows but the installer only finds the bootable USB drive (and cannot install on it since it's only 8GB) but not the SSD.

Bootable USB

I created a bootable USB with Rufus using GPT as the partition scheme and FAT32 as the file system. I've also tried every other combination but it hasn't improved anything.

BIOS Settings

I've also set the SATA mode to AHCI from BIOS. I also got my Windows to boot in that mode as well following advice I found during my research.

Secure Boot and Fast Boot are both disabled.

BIOS settings

SATA configuration settings

NVMe Configuration

Other info

When I tried to install or try out Ubuntu from the USB I got a black screen but adding "nolapic" as parameter fixed that. I don't know if that affects the installation at all.

Booting into the Ubuntu from the USB directly hangs on the desktop if I don't add "nomodeset" as a parameter.

While testing out Ubuntu from the USB I checked to see if it can find the SSD there but "fdisk" only returns the USB drive.

I've stopped Windows from hibernating. Apparently that can lock up the SSD somehow.

Lastly when selecting Install Ubuntu I get this wall of text before the installer launches. I have no idea what it is or if it matters.

5
  • May you please expand the "nvme configuration" and "sata configuration" inside of the bios and snap a picture of it? I would like to see what is available on those menu options. – Gordster Jun 24 '19 at 18:48
  • @Gordster I added images of both of those. The settings are very bare bones. – PancakeVader Jun 24 '19 at 19:03
  • 1
    Many need both UEFI updates & SSD firmware updates, even if new system. Check versions. Often easier with Windows. With nVidia you will need nomodeset to boot installer and first boot or until you install proprietary nVidia driver from Ubuntu repository. Issues are often common across various models of same brand: ubuntuforums.org/showthread.php?t=2414431 – oldfred Jun 24 '19 at 19:23
  • @oldfred UEFI and SSD firmare are all up to date as far as I can tell. So no luck there. – PancakeVader Jun 25 '19 at 2:52
  • Older thread & version. User did install, but does not have all the details: ubuntuforums.org/showthread.php?t=2375408 If nVidia you will need nomodeset boot parameter. askubuntu.com/questions/1026179/how-to-install-a-gtx-1060 & askubuntu.com/questions/61396/… Do you also have Windows fast start up off. Different setting than UEFI fast boot. Fast start up sets hibernation flag, so Linux NTFS driver does not see it. askubuntu.com/questions/843153/… – oldfred Jun 25 '19 at 3:40
2

After a good night's sleep I got Ubuntu to find the SSD. All it needed was adding another parameter: "pci=nomsi"

Thanks for the suggestions to everyone.

1
  • Fixed the problem for me! How to get to the screen where you should add this line: from the BIOS screen, press F8 for the boot menu => then select Ubuntu, quickly press ESC once to get to the GRUB screen => stand on Ubuntu and press e to edit. – DalyaG Dec 8 '19 at 7:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.