4

When typing in Ubuntu my cursor jumps around and its not application specific. It doesn't matter or Im filing in a web form, writing an e-mail or using LibreOffice or Lyx. Im using a Sony Vaio 64bit machine.

I read a previous question (link below) on this subject which indicates it may have something to do with the touchpad settings. As this has occurred in previous Ubuntu distros Im guess it is somekind of hardware issue.

  • Have you tried to turn off the tuochpad? Did it make any difference? – brownian Mar 23 '12 at 11:36
  • No, do i have to run the cmds from the linked question to have the ability to this? If so i will give it a try? askubuntu.com/a/71696/51556 – stephenmyall Mar 23 '12 at 11:44
4

Changing the cursor theme back to the default Adwaita (theme) in My Unity resolved this along with lowering the pointer speed and sensitivity in system settings >> mouse and touch-pad

2

This problem was driving me bonkers too. Finally I went to the Ubuntu Software Center, entered "touchpad" in the search box, found "Synaptiks" touchpad manager and installed it. Set it to start up at boot. Set it to lock touchpad when typing and set the delay time to 2 seconds. My problem is gone. It was so bad that I was looking for a non Ubuntu based distribution to replace the Ubuntu OS I have been using. Now I am very happy again. The old touchpad manager was supposedly sat to lock the touchpad when typing but it really was not. Good luck.

1

Try this, it worked for me Lenovo thinkpad L460

syndaemon -i 3 -d -t -k

syndaemon monitors keyboard activity and disables the touchpad when the keyboard is being used.

  • -i 3 will wait 3 seconds after the last key press before enabling the touchpad (default is 2.0s).

  • -d starts syndaemon at the background.

  • -t disables tapping and scrolling, not mouse movements, in response to keyboard activity.

  • -k ignores modifier keys when monitoring keyboard activity.

  • 3
    Whilst this may theoretically answer the question, it would be preferable to edit your answer to also explain what the command does. – Martin Thornton Sep 20 '18 at 12:54
0

My cursor does the same thing, though only when I use the LibreOffice Writer. I found this was due to two things:

  1. I do not have the proper keyboard drivers installed (and am having a hell of a time finding them for my Inspiron N5040).
  2. Turn off the auto-save option in which ever program you are using. I found that solved the problem for me.

I also tried turning down the sensitivity on my touch pad but the problem is that the touch pad sensor runs the full length of the keyboard on my laptop, and it might on yours too.

0

I went into activities, entered mouse as the search. waited like 30 sec. for the search to parse. settings / mouse & touchpad

Turned OFF touch to click. That solved my problem as just brushing the touchpad was being interpreted as a mouse click, causing focus to jump around, selecting text that then gets deleted by the next character, etc.

command line for the gui is: $ gnome-control-center mouse

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.