So I was working on my KDE Plasma desktop with a nice wallpaper I had chosen. However, when I started, I started using the "activities" feature and started regularly adding and removing activities I was faced with a problem: the new activities take the default Kubuntu wallpaper (at the time of writing this was Next) instead of my set wallpaper. I tried to follow the answer over here, but it didn't work, the background of new activities remained the same. In the process of modifying that file, I noticed something strange though: the wallpaper set there does not match the actual default wallpaper. Here is the file:

defaultWallpaperTheme=Elarun # The actual default wallpaper is Next!

I checked whether the Elarun theme (maybe) contains the Next wallpaper, and it doesn't

Any help is appreciated!

EDIT: The same happens when I connect an external screen and "extend" to it: it gets the default wallpaper.

  • Which version of Kubuntu are you on? The link you mentioned is for Kubuntu 14.04. – DK Bose Jun 22 '19 at 15:07
  • @DKBose, I am on Kubuntu 19.04. The link I mentioned is indeed for Kubuntu 14.04, I could not find any others that addressed my problem... – Linux4win Jun 22 '19 at 15:10
  • I don't use wallpapers or activities. If you don't get help here, try asking at Kubuntu Forums, or KDE Community Forums, or reddit/kde or reddit/kubuntu. – DK Bose Jun 22 '19 at 15:37
  • @DKBose, alright, thanks for your time! At least I have useful links to help me! – Linux4win Jun 23 '19 at 10:28

Alright, found an answer myself somehow. Apparently, new versions of KDE Plasma use another file than mentioned in the older answer. The new file is located at /usr/share/plasma/desktoptheme/(themename)/metadata.desktop and works pretty much the same way with the only difference that it is theme-specific.

The steps I suggest are:

  1. Copy the desktoptheme you are currently using to a folder with a custom name. (For example, copy Breeze /usr/share/plasma/desktoptheme/breeze to /usr/share/plasma/desktoptheme/canobreeze or so)
  2. Edit the metadata.desktop's defaultWallpaperTheme to the wallpaper you prefer.
  3. (Optional, but handy) Edit the metadata.desktop's name to something you like. This is to differentiate between your theme and the original one.
  4. Set the defaultWidth and defaultHeight. You can find the available sizes at /usr/share/wallpapers/(wallpapername)/contents/images. Please note: not all wallpapers shipped with plasma have the same sizes. For example: the Next wallpaper has a lot of sizes, while Canopee only has one. IF THE SIZE IS NOT SET CORRECTLY THE WALLPAPER WON'T WORK!!!
  5. Look in the System Settings for 'Workspace Theme' (or in plasma search 'Plasma Theme').
  6. Set the theme to your own, modified version (it has the name specified in the metadata.desktop file)
  7. And there it is: when you create a new activity or connect a new screen, you will get your custom wallpaper.
| improve this answer | |
  • I'm going to mark this as the accepted answer, but if you have any other way to solve this problem, please share it and maybe I'll mark that as the right answer. – Linux4win Jun 29 '19 at 18:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.