I just bought a Samsung NP700Z5B laptop. Gorgeous machine and great performance! I do 2 things when I get a new laptop:

  1. Format the HD and install Winblows from a CD to ditch the bloatware
  2. Install some variant of Linux on it (lately Ubuntu)

Step 1 worked fine (until earlier today), but I haven't been able to install Ubuntu on it for the past 3 days! I've tried Mint12, Ubuntu 12.04, Ubuntu 11.10, Ubuntu 11.04 and Ubuntu 10.04. The live CD and the installations all run fine and report no problems, but when I reboot grub is nowhere to be found! The system goes directly to Winblows! I've tried booting from the liveCD and re-installing grub via the chroot and purge & reinstall methods (https://help.ubuntu.com/community/Grub2) and neither makes a difference. I've also tried copying the boot sector:

dd if=/dev/sda of=linux.bin bs=512 count=1

and putting it on c: then setting bcdedit to add the entry to the Windows bootloader with no results.

Earlier today I decided to try and set my boot partition as an EFI boot partition ... bad choice, now I don't even have the Winblows boot loader.

I've officially ran out of ideas.

Tried calling Samsung, but they're closed (they'd probably say something stupid along the lines of "Samsung recommends Windows 7" ... I've had Dell say that to me).

Any help would be greatly appreciated.

Update 1

Tried re-installing 12.04 and now I get the screen continously turning off and back on, but still no sign of booting ... it has been doing it for 15 mins so far (I set the boot partition type to ext2 instead of ext4)

Update 2

Well ... this just gets better and better. I inserted the installation USB key to reboot it and the flickering stopped for about a minute (remained on) then it started turning off and on again


Try the alternate installer, and on the partitioning, select the "/" or either "/boot" partition, and put a BOOTABLE flag on it. It will work.

  • tried setting the bootable flag on both ... nothing worked. 12.04 LTS eventually worked, but the system was quite unstable, I think the 'ExpressCache' system probably didn't like it. I ended up putting it in a VM using VMWare unity. Seems to work fine for now. – copolii Mar 31 '12 at 0:55
  • Make sure "/" (or either "/boot" IF YOU HAVE ONE) partition are primary. Grub must be on a primary partition with a boot flag. Grub must be also saved to MBR on top, (normally /dev/sda, NOT /dev/sda#anynumber#). Can you confirm Grub appearance on boot? – crackout12 Mar 31 '12 at 19:23

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.