0

I have recently installed Ubuntu version 16.04 and trying to install ROS kinetic on my laptop. However, I got stuck at this point where after running sudo apt-get update.

This is the result:

Err:1 http://packages.ros.org.ros/ubuntu xenial InRelease
  Could not resolve 'packages.ros.org.ros'
Hit:2 http://security.ubuntu.com/ubuntu xenial-security InRelease              
Hit:3 http://id.archive.ubuntu.com/ubuntu xenial InRelease
Hit:4 http://id.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:5 http://id.archive.ubuntu.com/ubuntu xenial-backports InRelease
Reading package lists... Done
W: Failed to fetch http://packages.ros.org.ros/ubuntu/dists/xenial/InRelease  Could not resolve 'packages.ros.org.ros'
W: Some index files failed to download. They have been ignored, or old ones used instead.

I have searched for a solution online for quite awhile now, but still cannot seem to solve the issue.

1
  • 1
    If I open those links in a browser, I get 'site cannot be reached'. I don't know what the site is, or why you added it, but did you verify it's still there? or should it have been http://packages.ros.org/ros/ ?? (that works, and does support xenial/16.04) – guiverc Jun 22 '19 at 2:22
2

I suspect you have made a typo

replace your http://packages.ros.org.ros/ubuntu with http://packages.ros.org/ros/ubuntu/

as that actually gives me Oregon State University's Open Source Lab, which is I suspect what you're after.

3
  • Hello, thank you so much! However, after the correction Err:1 packages.ros.org.ros/ubuntu xenial InRelease Could not resolve 'packages.ros.org.ros' . . (Get some extra ...) . Fetched 5.223 kB in 7s (674 kB/s) Reading package lists... Done W: Failed to fetch packages.ros.org.ros/ubuntu/dists/xenial/InRelease Could not resolve 'packages.ros.org.ros' W: Some index files failed to download. They have been ignored, or old ones used instead. Still not able to fetch the files. I am so sorry. – Dr Drill Jun 22 '19 at 15:03
  • Please add additional information to your question, and leave me a comment to look there (formatting options are limited & detail hard to read in comments; we can help you to correct formatting in questions & answers). The error message contains the same wrong/typo packages.ros.org.ros link which needs correction to packages.ros.org/ros/ubuntu as mentioned. You possibly didn't save your correction? – guiverc Jun 22 '19 at 22:18
  • Thank you so much. Yes, indeed the correction was not saved. It worked. Thank you so much. – Dr Drill Jun 23 '19 at 3:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.