0

SO this might seem like there are a lot of answers for this but I have tried a lot of them and they all do not work. First the top result on google is from 2011, and so not working in 2019 of course.

and all the others seem to mention setting stuff in password and key-ring and
i do not seem to have that on my Xubuntu 18.04. My version though says

Distributor ID: Ubuntu Description: Ubuntu 18.04.2 LTS Release: 18.04 Codename: bionic

But im on Xubuntu. I search the start menu area for key ring and or password and nothing is there. I then apt-get installed key-ring from online command code and it says its already installed but I cant access it or see it. I go under settings and there is nothing for key-ring or passwords.

So I can use some help figuring out how to stop that password prompt from popping up please

thanks UPDATED INFO:

1. Yes I do have start gnome on startup checked under sessions and startup -> Advanced.

0

While it's true you're likely running XFCE on Xubuntu, that doesn't mean you can't run Gnome applications, especially Gnome Services.

Gnome Services helps enable commonly used applications, such as Gnome Keyring, and if it was running properly, should unlock when you login instead of asking for your password a second time.

You will want to keep Gnome Keyring, and be thankful that Chromium uses Gnome Keyring. Instead of saving your bank password in cleartext, Chromium is able to store your credentials more securely by encrypting them with your password.

Have you disabled Gnome Services? Can you make sure that they are enabled?

Applications Menu Settings > Session and Startup > Advanced

You may have to type the password into Chromium one final time, but you should be able to unlock the keyring on login, if you type your password to login.

Yes, it's annoying to have to type your password in multiple times, so enable Gnome Services, which will start the keyring when you log in. Even if you can't figure it out, it's worth typing in your password twice.

  • So I checked under the Advanced tab and there IS a check mark by enable gnome services at startup. But I may have disabled it some other way in the past trying to get the prompts to stop. Also I have it set so my system boots up without asking me for any password, although there is one. How DO I get the key rings back :-) – Norman Bird Jun 22 at 1:26
  • Ah, yeah so if you don't type in your password, I don't think it can be unlocked, which is why you're being asked to type your password in later. You have to decide: Do you want me to be able to take your laptop, turn it on, and login to your bank, or, do you want to prevent that by typing in your password to login? Sorry I couldn't help but please take that into consideration. – earthmeLon Jun 22 at 1:30
  • I have no idea how I initially disabled the password prompt at startup. I just went under user and was able to change password only. No option to reinable password prompt. Any idea? :-) – Norman Bird Jun 22 at 1:36
  • I finally se the password and keyring thing now :-) So I should be able to figure things out from here thanks. – Norman Bird Jun 22 at 2:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.