0

I get this error,

GEGL version too old!

GIMP requires GEGL version 0.4.16 or later. Installed GEGL version is 0.4.14.

Somehow you or your software packager managed to install GIMP with an older GEGL version.

Please upgrade to GEGL version 0.4.16 or later.

I've tried removing and reinstalling GIMP. I've tried removing and reinstalling GEGL. When I do, it appears it is installing 0.4.16. Same error every time. It was working just the other day. Version 2.10

I don't know what to try next.

  • I think it was originally installed by adding this repository, ppa:otto-kesselgulasch/gimp. So how can I get back to a working gimp? removing the repository and installing from the software center gives me the same error. – ticotexas Jun 21 at 16:26
  • @ticotexas can you list the steps - the exact ones, paste the command lines into your question - you used to add that PPA and install GIMP? – Michael Schumacher Jun 21 at 17:28
  • sudo add-apt-repository ppa:otto-kesselgulasch/gimp, sudo apt update, sudo apt-get install gimp – ticotexas Jun 21 at 18:22
  • At this point, I want to remove gimp, the repository, and start over fresh. I guess I need more explicit help to do this. I've tried sudo apt-get purge gimp, sudo add-apt-repository --remove ppa:otto-kesselgulasch/gimp, sudo apt update, sudo apt-get install gimp. This results in The following packages have unmet dependencies: gimp : Depends: libgimp2.0 (<= 2.10.8-z) but 2.10.12+om-1ubu19.04.1~ppa is to be installed Depends: gimp-data (<= 2.10.8-z) but 2.10.12+om-1ubu19.04.1~ppa is to be installed E: Unable to correct problems, you have held broken packages. – ticotexas Jun 21 at 18:29
2

I had to add the repo again. Then run, sudo apt install ppa-purge && sudo ppa-purge ppa:otto-kesselgulasch/gimp. After that, sudo apt-get install gimp was able to install and start normally.

1

When you say

I've tried removing and reinstalling GEGL.

you’ve been updating the standalone GEGL package. What GIMP needs is the libgegl package, which is not included in ppa:otto-kesselgulasch/gimp for some reason. I have submitted a bug report to the PPA maintainer.

0

You can force another version of libgegl. I dont know why, but the version 0.4.14 is showed as higher version than 0.4.16 so even when you have the 0.4.16 version it will be updated to 0.4.14. You have to force version 0.4.16 and downgrade the 0.4.14 to 0.4.16 version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.