1

I installed Ubuntu 19.04 and Docker. I'm running some home automation containers on them. Everything was fine and I was happy.

Recently one of my friends modified my user permission allowing me to run Docker without needing to type sudo docker every time. It worked fine, but yesterday I was trying to install some stuff and I got this error message:

myusername is not in the sudoers file. This incident will be reported.

I looked for solutions, and found that all I have to do is boot into recovery mode and add myself back as a sudo user to sudoers.

I have tried every possible way to boot into recovery mode, but none of them worked including press holding/repeatedly the Shift up/down and Esc keys when booting.

I can boot using Ubuntu live, here is the out put of Sudo dmidecode t1, running Ubuntu 19.04 on INTEL NUC with USB keyboard.

# dmidecode 3.2
Getting SMBIOS data from sysfs.
SMBIOS 2.8 present.

Handle 0x0001, DMI type 1, 27 bytes
System Information
    Manufacturer:                                  
    Product Name:                                  
    Version:                                  
    Serial Number:                                  
    UUID: cba03300-5880-11e5-84c0-b8aeed7952bf
    Wake-up Type: Power Switch
    SKU Number:                                  
    Family:  
  • It could be of a help to provide the Ubuntu version you are using. :) And I think also, that the backgorund (Docker, home automation and so one) is not relevant to your question as you want to enter the recovery mode. Maybe you want to remove the first part? – Yeti Jun 21 at 13:01
  • Are you able to boot with a live-linux? then show sudo dmidecode -t1 Please edit your question for that. – nobody Jun 21 at 13:22
  • @karel, I tried to follow the steps but as I mentioned I lost Sudo access and cannot edit grub. – Prabhu Thiagarajan Jun 22 at 6:45
  • 1
    Possible duplicate of How to start Ubuntu in Console mode – Fabby Jun 22 at 19:52
  • 1
    Finally I got it fixed by resetting the root password using the live Ubuntu and add me back to sudo group. – Prabhu Thiagarajan Jun 24 at 7:20

protected by Thomas Ward Jun 21 at 13:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.