0

According to the Terminator man page, I can use the --command flag when running the terminator command to run a command when the terminal window opens. However, I can't seem to get it working. I've tried the following:

terminator --command="ls"
terminator --command ls
terminator --command "ls"

The first step is to get this working. Secondly, the man page also points out that it will run the command "instead of your default shell or profile specified command." Does that mean aliases from my .bashrc file won't be loaded in? If so, how can I have them load in?

The full command I'm going for is something like this:

terminator --command ssh-apixel --geometry 900x575+110+55 --new-tab

where ssh-apixel is an alias defined in my .bashrc file.

  • Before asking this question, did you test it works with another command, e.g. "top" – vanadium Jun 21 '19 at 7:46
  • @vanadium Yes, I've tried it with multiple commands – APixel Visuals Jun 21 '19 at 7:48
0

Here's what worked for me in the end:

terminator -e "bash --rcfile <(echo '. /home/apixel/.bashrc; ssh user@xxx.xxx.xxx.xx')" --geometry 900x575+110+55 --new-tab
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.