0

After my first install of Ubuntu 18.04.2LTS, my PC boots to the Grub command line. (Not a splash screen). UEFI.

How do I set this up so that I don't have to go through this process every time I want to use Ubuntu?

How do I boot my PC from GRUB?

To boot, from grub, I have to do the following from the above post:

Ok, from grub type ls (hd0,1)/ you should see a file named vmlinuz or linux, and initrd.img

Type linux (hd0,1)/vmlinuz root=/dev/sda1 or linux (hd0,1)/linux root=/dev/sda1 depending on what you found with ls (hd0,1)/, then:

initrd (hd0,1)/initrd.img boot

I have several hard drives in my computer (self-built). I select the drive i'm going to boot from in the UEFI utility. It currently defaults to my Windows drive as I will use Windows more frequently than Ubuntu.

  • So are you then able to manually boot? Did you then reinstall grub? Is your install UEFI or BIOS? May be best to see details, use ppa version with your live installer (2nd option) or any working install, not older Boot-Repair ISO: Please copy & paste link to the Boot-info summary report ( do not post report), the auto fix sometimes can create more issues. help.ubuntu.com/community/Boot-Repair What brand/model system? – oldfred Jun 19 at 21:46
  • See: askubuntu.com/questions/1104855/… let us know if accepted answer works for you – WinEunuuchs2Unix Jun 19 at 21:51
  • Thanks @WinEunuuchs2Unix . Here are the results of the Boot Repair report: paste.ubuntu.com/p/GkHmr2F84Y It says "The boot files of [The OS now in use - Ubuntu 18.04.2 LTS] are far from the start of the disk. Your BIOS may not detect them. You may want to retry after creating a /boot partition (EXT4, >200MB, start of the disk). This can be performed via tools such as gParted. Then select this partition via the [Separate /boot partition:] option of [Boot Repair]. (help.ubuntu.com/community/BootPartition) --- Could this be the cause? – Skubalon Jun 19 at 22:00
  • The report says it was successfully repaired. Does it boot ok now? – WinEunuuchs2Unix Jun 19 at 22:03
  • No, it does not. Still boots to Grub command line. – Skubalon Jun 19 at 22:04
0

Booting from my installer USB stick, I created a boot parition using gParted, following these instructions: https://help.ubuntu.com/community/BootPartition

I made sure that the boot partition was at the front of the disk.

But Boot Repair detected an EFI and recommended I separate the boot/efi partition from the /boot.

So, using gParted, I created an EFI partition. https://help.ubuntu.com/community/UEFI#Creating_an_UEFI_partition Scroll down to "Creating an EFI System Partition"

Once I did that, I was able to select the EFI partition in Boot Repair. I followed the prompts until it was time to reboot.

When I got to my UEFI boot selector, I had 2 instances of "ubuntu" and 1 instance of the actual hard drive name. Selecting either of the "ubuntu" took me to Grub. But, when I selected the hard drive name, it booted the OS directly.

FYI--I only have Ubuntu on this drive. This is not a dual boot. I have Windows installed on an entirely separate drive.

Can I get rid of one of the instances of "Ubuntu" in the UEFI boot selector? If so, how and which one?

I don't know exactly how these changed fixed my issue, but they did. Thank you all for your help!

  • To be clear, now you have two EFI partitions, one in the hard drive with Windows, and another in the hard drive with Ubuntu. If so please edit the answer and add this detail. That will make the answer better. – user68186 Jun 20 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.