0

My Ubuntu screen resolution is far too low, and there is no option to change it to a different resolution in settings. I have a GTX 1650 graphics card, so I believe the problem is that the correct Nvidia graphics card driver is not installed. Am I correct?

I downloaded the correct driver but I am having trouble installing it because I don't really know how to stop the X server and get into text only mode. (I'm new at this.)

Would you mind walking me through the steps necessary to install the correct driver and get my resolution working?

2
  • 1
    Do not install from the binaries downloaded from Nvidia. Instead add the graphics drivers PPA and then just open Additional Drivers and there select and apply the latest version. – user880592 Jun 19 '19 at 15:19
  • A good post on adding PPAs in general is found at askubuntu.com/questions/496495/… and askubuntu.com/questions/760934/… has instructions to add the PPA for graphics. To get into a text only terminal screen, press {Ctrl-Alt-F1} – K7AAY Jun 19 '19 at 16:32
2

@GabrielaGarcia This worked:

Do not install from the binaries downloaded from Nvidia. Instead add the graphics drivers PPA and then just open Additional Drivers and there select and apply the latest version.

I used the following commands:

sudo add-apt-repository ppa:graphics-drivers/ppa

sudo apt install nvidia-driver-430 nvidia-settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.