your installation medium is on dev/sdb1. You will not be able to create, delete, or resize partitions on this disk, but you may be able to install to existing partitions there.

I have gotten the above message while trying to install Ubuntu. I am reinstalling Ubuntu because of a crash that rendered me unable to boot Ubuntu so I decided to restart the reinstallation process only days after installing for the first time. This message appeared after I tried to change dev/sdb1 fat32 to ext2 in order to install Ubuntu to that partition. After I got this message I tried to select dev/sdb1 and press change but nothing happens no matter how long I wait for a response. I can’t format to fat32 as no root file system is defined. It tells me to correct this from the partitioning menu. To be honest, I am completely new to Ubuntu and have no idea how to proceed at this point. I can’t install Ubuntu and can’t click change on dev/sdb1 fat32. Maybe I should try to completely wipe my disk clean? If needed I am able to access the terminal by entering try Ubuntu. Any help at all would be appreciated, thanks :)

  • 1
    your installation medium is on dev/sdb1. You will not be able to create, delete, or resize partitions on this disk: Translation: you cannot install Ubuntu to the same disk from which the installer is running -- you need to install to your hard disk. If you've been fidgeting with the partitions on the USB installer you might need to re-create it. Assuming you have made proper backups, my suggestion is to wipe your disk of all partitions, format as GPT, and allow the Ubuntu installer to set up your partitions through Guided mode. You really do not want a FAT32 file system for a modern OS – Nmath Jun 19 '19 at 14:52
  • 1
    You will probably want to format to ext4 instead of ext2 on the disk you install to. – crip659 Jun 19 '19 at 15:26
  • Just a note to say that, I too recently installed 18.04, and after a software update, it would not boot. Oddly enough, I unplugged all USB devices and it booted perfectly. Weird. – qweequeg Jun 19 '19 at 15:39
  • If sdb1 was FAT32 was it an UEFI install? You should install in same boot mode as previous install, unless you had BIOS install but have UEFI hardware & want to upgrade to UEFI boot. – oldfred Jun 19 '19 at 17:45
  • Thanks for all the replies, sorry I took so long to see them. I’ll try all the methods listed and update the thread if the problem is solved. Thanks a mill 👍 – Shahin Hou Jun 20 '19 at 10:33

When you make an installation, the installer detects two disks (or more): your USB and the hard disk of your computer.

(Generally)[*] The names of the disks will be:

USB: /dev/sdb

HARD DISK: /dev/sda

And the partitions of each disk is a number added to the name /dev/sda1, /dev/sdb1, etc.

When performing the installation, you have to ensure that you select your HARD DISK (/dev/sda), not your USB (/dev/sdb), and beware that the boot loader (GRUB) is installed on your sda.

[*] On some situations, the installer may detect the USB as /dev/sda

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.