1

I've tried the following:

  • sudo apt install --reinstall ubuntu-software
  • sudo apt update && sudo apt upgrade

Running on Ubuntu 19.04 and tried with Pi-hole disabled.

screenshot

Thanks

2

I found a fix:

sudo apt autoremove gnome-software && sudo apt install gnome-software
1

As my snap store app was apparently hanging and the search function was not working properly, I decided to install gnome-store in my ubuntu 20.04 and removed the snap store. However, I later changed my mind and decided to re-install the snap store. But to my surprise, it was showing a snap store, not ubuntu software. The steps I followed to reclaim the old ubuntu software (snap store) are:

  1. Completely removed and purged gnome-software using sudo apt purge gnome-software

  2. Then removed the snap-store using snap remove snap-store

  3. Then re-installed snap store using snap install snap-store

  4. To regain the standard ubuntu icon, use the following command:- snap refresh snap-store --channel=stable/ubuntu-20.04

This fixes the issue !!

0

For me, ending the process and re-opening solved the error.

  1. Open System Monitor and search for 'snap-store' process.
  2. Select the snap-store process and click 'End Process'.
  3. Re-open Ubuntu Software

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.