Mac OSX - Snow leopard is host OS and Ubuntu-10.1 and windows xp are guest OS.

I recently updated vittualbox to 4.1.10

  • Ubuntu did not boot immediately, it did an entire system scan and took about 2 hrs to boot. Now it boots regularly but it does not find wireless internet connection, even connecting cable does not help. However internet works great in window xp.

I am totally lost, I would appreciate your help


If you have the Guest Additions installed, try upgrading them to the latest version, which should be included with the upgrade.

(comment from OP)

disable Adapter-1 and enable Adapter-2 with bridge connector instead of NAT and it worked.

|improve this answer|||||
  • 1
    I disabled Adapter-1 and enabled Adapter-2 with bridge connector instead of NAT and it worked. – Raama Mar 23 '12 at 2:12

When I've seen this problem it's because the underlying virtual network card has changed.

If you clear out the settings from /etc/udev/rules.d/70-persistent-net.rules on the Ubuntu guest. Then restart the guest. It will reassign the 1st detected network device to eth0.

The other work around is to tell ubuntu to use eth1 to get on the internet.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.