I have installed Ubuntu 16.04 alongside Windows 10 like this, with the 64.77 GB partition being used for Ubuntu :

enter image description here

Whenever I restart/start my PC (Elitebook 8560w Workstation HP) the grub selection menu does not come directly, I have to:

  • Keep pressing ESC, until the boot menu comes up,
  • Press F9, I can select the hard-disk that I want to boot from (SSD or hard disk).
  • Only now does the normal grub menu shows up.

Otherwise, I will encounter the "unknown file system" error and nothing happens.

I have tried the following solutions already to no avail:

However, none of them could work!. Moreover, writing ls to grub rescue shows only (hd0) and ls (hd0) shows again unknown filesystem error. So I am not able to move forward with this terminal solution.

Is there any possible case/solution for my situation?

  • So you have two disks? Jun 18, 2019 at 22:03
  • @Yufenyuy Please review my edits as I had to edit yours to make it clearer...
    – Fabby
    Jun 18, 2019 at 22:40
  • @Fabby, it's Ok. I actually thought it was okay to leave Cloudinit unchanged. So instead of editing it to Cloud-init ... I left it unchanged. Jun 18, 2019 at 22:43
  • @YufenyuyVeyehDider Please scroll down and compare your edit with mine: it's not just about grammar and spelling but overall logic and readability (e.g. showing the picture). Please also review the editing help to improve the readability of your your own edits in the future as from this point forward I'll just decline them if they're no good.... ¯\_(ツ)_/¯
    – Fabby
    Jun 18, 2019 at 22:48
  • @Fabby, Okay thank you. Jun 18, 2019 at 23:36

2 Answers 2


Windows 10 Anniversary Update, and the more recent Windows 10 Creators Update, have a really bad habit of wiping out Linux partitions on MBR disks. Microsoft has known about this bug for quite some time, but has chosen not to fix it. Sounds like you're a victim.

Recovery is possible, but it can be tricky.

Boot to the Ubuntu Live DVD/USB.

Open Software & Updates and make sure that all of your software repositories (except proposed) are enabled.

In terminal...

sudo apt-get update           # update the software database
sudo apt-get install testdisk # install testdisk
man testdisk                  # read the manual
sudo testdisk                 # start testdisk

You can also get specific instructions here: http://www.cgsecurity.org/wiki/TestDisk_Step_By_Step

Help for photorec here: https://www.cgsecurity.org/wiki/PhotoRec_Step_By_Step

Note: after recovery, strongly consider changing your MBR formatted disk to GPT format, so future MS updates won't wipe it again.


I could solve the problem by

  • Activating UEFI boot ( it was working with Legacy since UEFI is not recommended for my HP)
  • Changing boot priority order in UEFI to OS Boot Manager at top

I did not have enough time to try the other solutions, but I appreciate them as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .