0

I have read the other related articles, but have not been able to resolve this issue. Either the scenario is not applicable, or I do not fully understand the subject matter, as one who has been a microsoft guy for 25 years.

I have decided to venture into the Linux pool, but I have to say that after 2 weeks of reading and loading and configuring a working FOG server, only to have it rendered unusable by a software update, has put a kabosh on some measure of my enthusiam. A trust issue right out the door is not a good thing. Anyway-

Im running a fresh load of 18.04LTS with FOG 1.5.6. Neither are upgrades from prior versions.

Today (18.June.2019) the system had another batch of software updates to load. After reboot, the system goes straight to GNU GRUB menu. Nothing in this menu will get me past it.

Linux 4.18.0-22 generic tops the Grub menu

Please advise. (in beginner dialect) Very much obliged.

  • Does the grub report any error? – guillermo chamorro Jun 18 at 16:59
  • Welcome to AskUbuntu! I admit it's a shot in the dark without a full report, but did you try to reboot and hold the Shift key (Escape if you are on UEFI, on most systems afaik) to access the GRUB (not recovery) menu, and selecting your previous kernel? – Alessandro Flati Jun 18 at 17:03
  • Thank you, Alessandro.. I just did (UEFI). I don't get a menu. I get what appears to be a terminal. Hitting 'Tab' reveals a long list of 'Possible Commands'. from the first grub menu, I can select 'Advanced Options for Ubuntu'. Choosing that option will bring me to a list of what I assume are kernels. None of them will boot when selected. – qweequeg Jun 18 at 17:18
  • Thank you Guillermo.. How would I view errors? Im only seeing a menu. – qweequeg Jun 18 at 17:25
  • Then I'm afraid you'll save time reinstalling the whole thing from scratch, rather than trying to repair it. If you really need to debug, you could try posting here the result of (in GRUB> rescue mode): ls: this should show you a list of HD devices (where hopefully your initramfs is stored). You can navigate through them as in a normal shell, like ls (hdX), and you should find one that contains the path (hdX)/boot/grub. If so, please type set root=(hdX) followed by set prefix=/boot/grub (or set prefix=(hdX)/boot/grub), then lsmod normal (or insert normal) and normal – Alessandro Flati Jun 18 at 17:33
0

The issue was caused by a plugged-in USB headset. Because I was unable to perform any of your suggestions, I felt it had to be either a damaged disk, or something incredibly stupid.

After a successful disk check, I unplugged all USB devices from the PC as a last measure before doing a reload, and it booted-up perfectly.

  • Some USB-stuff does tricks; e.g. at least one USB-to-ETHERNET adapter brings up not only the USB-thingie, but also a DRIVE containing the Driver software (brand names: Dell, Realtek) – Hannu Jun 20 at 8:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.