0

I'm the only user on the login screen. Upon hard booting after a freeze, my username used to be highlighted automatically, so I could login by only using the keyboard. Now, my username is no longer highlighted automatically, so I have to mouse-over, click, then type. Is there a way to have my username highlighted upon boot?

  • 1
    At the login screen, try hitting the TAB (or down arrow) key and see if your username is highlighted. If so, hit ENTER, then enter your password, hit ENTER again. Report back. If that works, I'll put together an answer so you can accept it, ok? – heynnema Jun 18 at 19:37
  • @heynnema, both TAB and up arrow highlighted my username. Thanks! – ticotexas Jun 19 at 14:08
  • I need to revisit this. I've found that if I catch the login screen before it times-out and goes dark, I can hit enter on my highlighted username. But if I leave for a while and come back when the screen has gone off, if I wake up the screen, my username is no longer highlighted and TAB and arrow keys do nothing. I think I may just have to live with this. – ticotexas Aug 15 at 21:27
1

From the comments...

At the login screen, hit the Tab, or Up/Down arrow keys, to select your username, hit Enter, enter your password, hit Enter again, and you're in!

Update #1:

Create another user account, with an alpha name that comes after your own username. This way, one account will always be highlighted on the login screen, and you can move between them, if required, using the arrow keys, as above.

To stop the system freezing, increase your swap to 4G. Your current swap could be on an existing disk partition, or in a /swapfile. Review/edit /etc/fstab for the swap mount command string. Search here on AU for the procedure on how to do this.

  • Strangely, this does not work after reboot now. But it does work after logout. I have to click my username with the mouse after reboot still. – ticotexas Jun 20 at 13:41
  • @ticotexas otherwise, just create a new user with a username that comes after your username, so that two usernames will appear on the login screen, and then it should work again. – heynnema Jun 20 at 13:54
  • I'm figuring it out a bit more. Sometimes if Ubuntu freezes up, I have to hard boot by holding down the power button, then press it again to start up. Then my username is not highlighted. I just soft booted normally and my username was highlighted. I will report back when I try hitting the first letter next time I have to hard boot. – ticotexas Jun 21 at 15:36
  • @ticotexas freezing huh? That's not normal. Edit your question and show me free -h. – heynnema Jun 21 at 16:23
  • 1
    You're freezing because your swap is way too small. Resize it to 4G. Swap could be on a disk partition, or in a /swapfile. Search here on AU for the procedure on how to resize it. – heynnema Jun 21 at 16:39
0

Just go to settings, navigate to details tab and then to users. There you'll find automatic access.

  • I don't want automatic login, but I would like my username highlighted automatically on the login screen. – ticotexas Jun 18 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.