0

I have seen several putative answers to my question, but none of them work.

Generally I keep the touchpad switched off, since it seems to play hell with the pointer jumping about into unwanted places. But once in a while my mouse freezes up and I would like to be able to use the touchpad to get something or other going. The problem is that enabling the touchpad seems to require the use of the mouse, and if this is frozen then I am stuck. I would like to enable the touchpad from the command line. As I said I have seen several suggestions, but none of them work.

(1) xinput list

followed by xinput --list-props nn

where "nn" is the ID for "SynPS/2 Synaptics TouchPad" given by the initial "xinput list".

Problem: there is no such item given when I do "xinput list".

(2) Use "Fn+F1" to toggle the touchpad, after having done

sudo apt install xserver-xorg-input-synaptics

When I do this "sudo apt install" manoeuvre I get told that "xserver-xorg-input-synaptics is already the newest version".

However "Fn+F1" has no effect at all.

(3) synclient TouchpadOff=1 to disable the touchpad and synclient TouchpadOff=0 to enable it.

No error messages given, but nothing at all happens.

Any other ideas?

Note that my "TouchPad Indicator" on my top menubar works just fine, but of course I can't use this when I actually need to, which is when my mouse is frozen. Catch 22.

I have now had two responses, one from Stephen Boston, suggesting that I look at function keys other than F1 (one with "Square with a diagnoal line through it -- maybe?"). No such key on my keyboard; my laptop is a Dell "Latitude E7470" (???). tried all of the function keys, one at a time, holding down the "Fn" key and pressing a function key. Nothing at all happened with any of them, except that "Fn-F11" toggles an expansion of the current window. No enabling of the touchpad eventuated.

The other response was from "PRATAP" who suggested that

https://askubuntu.com/a/1140700/739431

might be a workaround. I tried to do what this link suggested:

xmodmap -pke | grep TouchpadToggle

produced

keycode 199 = XF86TouchpadToggle NoSymbol XF86TouchpadToggle

So I then did

xmodmap -e "keycode 199 = XF86TouchpadToggle"

in accordance with what I understood the instructions to be.

After doing this I tried "Fn+F5" --- not a sausage --- and "Fn+F1", likewise.

I don't understand step 2 of the instructions "check the symbol on keyboard which is given for Toggling of Touchpad.. in mycase it is on F5 #Change F5 with your key on keyboard".

As far as I can see NO symbol on the keyboard is "given for Toggling of Touchpad".

If I do

xmodmap -pke | grep F5

I get

keycode  71 = F5 F5 F5 F5 F5 F5 XF86Switch_VT_5

which is exactly the result in the given example.

So I then tried (hammer and hope; no clue what is going on!)

xmodmap -e "keycode 71 = XF86TouchpadToggle"

The first time I tried "Fn+F5" the touch pad seemed to be toggled on, and I thought I had a success. But it wouldn't toggle off again. I turned off the touchpad using the icon on the top menu bar. Then "Fn+F5" had no effect thereafter.

This is exasperating.

And the exasperation continues. The

synclient TouchpadOff=0

construction (recommended by "bistoco") does NOT work for me. (I also tried it with a lower case "o" in the "Off"; same result.)

Why do computers pick on me???

  • Most laptops have a toggle key to enable/disable touchpad. In all of mine, this has been on the top row of keys with a cryptic icon and requires a hold on the keyboard's 'function' button.. Square with a diagnoal line through it -- maybe? Are you sure you don't have one? – Stephen Boston Jun 17 '19 at 23:49
  • may be a workaround askubuntu.com/a/1140700/739431 – UnKNOWn Jun 18 '19 at 1:08
0

This works for me

synclient Touchpadoff=0

Here is an answer with a bash script

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.