1

I opened Avidemux 2.7.3 GUI (Latest version in the Mint/Ubuntu repo) queued several videos I wish to convert from various formats.

I could 'save' the file in the GUI. Conversion worked great, as always.

Opened up the avidemux_jobs program. There are the movies waiting to go. If I press 'Run Jobs' button. It runs through the entire list, failing, one after the other. (7 seconds each). If I right click and select 'Run Now' the individual job fails.

5
  • Please mark as [solved] Jun 17 '19 at 14:18
  • 1
    It's question-and-answer site, if you want to share your findings, it should be done in the proper way. I have removed the solution part from the question, but you should be able to find it here. Please post the solution in the answers section below by clicking the 'Answer your question' button. Also 'marking as solved' is completely up to you. You can "accept" an answer (the most helpful one) by clicking the tick mark next to it (for a self-answer you'll be able to do that 2 days after the question is posted).
    – pomsky
    Jun 17 '19 at 14:26
  • I'm voting to close this question as off-topic because more a comment than a question.
    – vanadium
    Jul 1 '19 at 19:22
  • @pomsky Thank you for your edits and making my solution fit within the site's guidelines. Jul 31 '19 at 12:30
  • Improved this question by removing part of the solution added by OP to the original question. Question should now be on-topic, problem still persists with Avidemux 2.7.8, so the workaroung provided still is relevant.
    – marianoju
    May 12 at 10:21
2

Solution was simple, a kludge, but works for now. Make a soft link in /usr/bin/avidemux3_cli pointing to avidemux2.7_cli and another avidemux3_qt5 pointing to avidemux2.7_qt5.

sudo ln -s avidemux2.7_cli avidemux3_cli

sudo ln -s avidemux2.7_qt5 avidemux3_qt5 

After this, all worked as expected.

(source: originally posted by OP in the question body)

2
  • The underlying problem persists nearly two years later with Avidemux 2.7.8 (installed from the PPA provided by UbuntuHandbook ppa:ubuntuhandbook1/avidemux on Ubuntu 20.04). Soft linking avidemux3_qt5 to avidemux2.7_qt5 worked for me, soft linking /usr/bin/avidemux3_cli to avidemux2.7_cli did not work for me.
    – marianoju
    May 12 at 7:43
  • Avidemux 2.7.8 (installed on Ubuntu 20.04 from the PPA provided by xtradeb applications ppa:xtradeb/apps) shows similar problems. Soft linking is not possible/necessary. /usr/bin/avidemux3_cli is not installed. When running “Avidemux Jobs” the option “use Qt version” has to be checked, otherwise all jobs will fail.
    – marianoju
    May 12 at 10:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.