0

I have a second hard drive in my system that I want to make sure gets mounted to /mnt/HDD every time on boot-up. I added this line for it to my /etc/fstab file:

UUID=5A767B7E767B59A9                     /mnt/HDD       ntfs    rw,suid,dev,exec,auto,nouser,async   0 2

Well, it seems to work. My hard drive mounts to this system every time. However, when I try to delete files or folders, I get this error every time:

Unable to find or create trash directory for /mnt/HDD/test

I'm still able to delete files and folders using rm in console, but it's obviously inconvenient. Is there any way to fix this?

Edit: It may also be worth noting that when I created the folder using mkdir /mnt/HDD, I couldn't interact with the folder outside of root. So I did sudo chmod -R 777 /mnt/HDD. I did all of this before adding my HDD to the fstab file.

  • 2
    Possible duplicate of Unable to find or create trash directory? - check all of the places where you may have removed or altered your trash directory ~/.local/share/Trash/ in your user, and /.Trash-1000 in the mounted directory - also try to manually unmount / mount – Nmath Jun 16 at 21:15
  • Find out your UID with id -u and add uid=xxxx to your mount options. – mook765 Jun 16 at 21:26
  • 2
    Linux cannot run filecheck (chkdsk in Windows), so last parameter should be 0 not 2. I have seen these as better parameters for mounting. ubuntuforums.org/showthread.php?t=1983336 defaults,nls=utf8,umask=000,uid=1000,windows_names or ubuntuforums.org/… nodev,permissions,windows_names,nosuid,noatime,async,big_writes,timeout=2,fstype=ntfs,uid=1000,gid=1000,fmask=0002,dmask=0002 The big_writes mount option does help performance greatly. – oldfred Jun 17 at 3:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.