3

I am trying to set up my HP LaserJet P1102 on Ubuntu 19.04.

I know the theoretical procedure to install the printer, but this procedure does not work for me, following the "correct" procedure to install the printer (the software + the plugin) fails as follows.

I have downloaded and installed hplip 3.19.5 from here.

At first the installation seems to succeed. It asks for plugin to be installed, then it says "Plugin installation successful". But after I click OK on this message, it returns to the window in which I should choose which printer to install, and another message pops up:

error: The device you are trying to setup requires a binary plug-in. Some functionalities may not work as expected without plug-ins. Please run 'hp-plugin' as normal user to install plug-ins. Visit http://hplipopensource.com for more infomation.

error: hp-setup failed. Please run hp-setup manually.

  • 1
    Run hp-check and see if any error messages come up. In most cases hplip needs some more packages to function, and it can't install these by itself. You might be getting a number of error: 'libxxx' package is missing/incompatible messages. If so, simply do sudo apt install libxxx and try again. – Jos Jun 16 '19 at 15:25
  • @N0rbert I am sorry but it really isn't. Your link explains the procedure to install the plugins, the point is that this procedure (neither the basic one nor the advanced one) works for me – raffaem Jul 21 '19 at 8:53
  • @raffamaiden I was really assured that HPLIP from deb-package is stable and usable, but it is buggy. So I retracted close-vote / duplicate. – N0rbert Jul 21 '19 at 9:48
  • 1
5

Same here. I solved this way:

please run:

hp-setup -g &> ~/hp-setup.log

after your error read the log:

cat ~/hp-setup.log

you will find some lines like:

hp-setup[19265]: debug: Either /usr/lib/i386-linux-gnu/sane/libsane-hp2000S1.so file is not present or symbolic link is missing

if you run:

locate libsane-hp2000S1

you will get the right place like:

  • /usr/lib/sane/libsane-hpgt2500-x86_64.so.1.0.22
  • /usr/lib/sane/libsane-hpgt2500-x86_64.so.1.0.27
  • /usr/lib/sane/libsane-hpgt2500.so
  • /usr/lib/sane/libsane-hpgt2500.so.1
  • /usr/lib/x86_64-linux-gnu/sane/libsane-hpgt2500.so
  • /usr/lib/x86_64-linux-gnu/sane/libsane-hpgt2500.so.1
  • /usr/lib64/sane/libsane-hpgt2500-x86_64.so.1.0.22
  • /usr/lib64/sane/libsane-hpgt2500-x86_64.so.1.0.27
  • /usr/lib64/sane/libsane-hpgt2500.so /usr/lib64/sane/libsane-hpgt2500.so.1

now you only have to make a symbolic link:

sudo ln -s /usr/lib /usr/lib/i386-linux-gnu

sudo ln -s /usr/lib64 /usr/lib64/x86_64-linux-gnu

run again hp-setup

done

  • 3
    Thank you, that was the problem. On a side note, you can run cat hp-setup.log | grep "file is not present" to discover exactly which files are not found. For me, the line to run was sudo ln -s /usr/lib/x86_64-linux-gnu /usr/lib64. For some reasons, hp-lip seems to look for the libraries into /usr/lib64/x86_64-linux-gnu instead of the correct /usr/lib/x86_64-linux-gnu. May it is worth to report that as a bug. – raffaem Jul 21 '19 at 9:27
  • 1
    It seems that bug was already reported as bugs.launchpad.net/ubuntu/+source/hplip/+bug/1825717 . So HPLIP from Ubuntu 19.04 deb-package is buggy (it is other bug I have reported now). – N0rbert Jul 21 '19 at 9:47
  • Thank you so much, I don't know why this worked, but it did. Good job boys! – El borito Nov 11 '20 at 8:24
3

I also had the problem where the HP printer installs fine but the scanner plugin does not install (Ubuntu 19).Disabling the plugin.py worked!!! (thank you) but I had to install apparmor-utils first.

sudo apt install apparmor-utils
sudo aa-disable /usr/share/hplip/plugin.py
hp-plugin

The last step runs the HP Plugin installer which is needed for printer scanning to work.

1

I had a slightly different problem. My HP Printer installed fine, but the scanner plugin would not install properly. It seems the trick was to get AppArmor to lower its shields for a Python script.

Edit: Looking at other answers, it looks like it is common to not have AppArmor utils installed, so you may also need to install it first

sudo apt install apparmor-utils

sudo aa-disable /usr/share/hplip/plugin.py

After I did this, the plugin installed correctly.

0

After following Kai Kramer's answer here I got:

error: Python gobject/dbus may be not installed
error: Plug-in install failed.

AND

cannot access '/var/lib/hp/hplip.state': No such file or directory

A search on the web got me to try the following and it worked:

$ aa-disable /usr/share/hplip/plugin.py

Command 'aa-disable' not found, but can be installed with:

sudo apt install apparmor-utils

Install apparmor utils (mind you I didn't have it installed!!!)

sudo apt-get install apparmor-utils

Then run

sudo aa-disable /usr/share/hplip/plugin.py

& the run as normal user, not as root:

hplip-plugin

Now my printer (laserjet 1020) was installed.

Source: https://bugs.launchpad.net/hplip/+bug/1813768

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.