0

On my MacBook pro 2010 I have Ubuntu 18.04 and the sound is working. By the way, I have to start in terminal mode because the related issue of the graphic card for these 2010 MacBooks.

Then on the same MacBook, I installed Xubuntu because I think the ressources are better used with this GUI and the hybernation is working better as well. Unfortunatelly the sound does not work with Xubuntu; I do not know why.

I start Ubuntu Gnome GUI with:

  • startx

-> and the sound is working

I start Xubuntu like this:

  • cd /etc/init.d
  • sudo lightdm start

-> and the sound does not work (I have a virtual audio output)

Do you have some ideas or things I could do to make it work on Xubuntu and why it works on the Gnome UBUNTU GUI ?

0

Try to reload alsa mixer using terminal like this :-

 sudo alsa force-reload

If this doesn't work then try to reinstall alsa mixer

 sudo apt remove --purge alsa-base pulseaudio

 sudo apt install alsa-base pulseaudio
  • Thanks your answer, but it did not work. – user966471 Jun 17 at 8:53
  • Then try this:- install 'qasmixer' then go into the menu and choose 'Settings > Sessions and Startup > Application Autostart > Add' and name it whatever you want (i.e Volume Control) then for the command type in: qasmixer --tray then reboot. – Ronak Khangaonkar Jun 17 at 9:55
  • Hi, it did not work either. I have now two volume control: the one of qasmixer and the older one. Still no output hardware device ; just the virtual on Xubuntu. I will resign myself to use Gnome :-|. Now I am just curious to understand why that works on Gnome and doesn't with xubuntu... Regards – user966471 Jun 18 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.