0

I am trying to setup network bridge on 18.04 VPS with 2 IPs and right after applying netplan apply, internet stops working while all configuration and adresses are good: ip -c addr and ifconfig shows no ip on ens18, but correct IPs, gateways and broadcast on br0.

My netplan config:

network:
  version: 2
  renderer: networkd
  ethernets:
    ens18:
      dhcp4: no
      dhcp6: no
      match:
        macaddress: 00:50:56:3e:23:56
  bridges:
    br0:
      interfaces: [ens18]
      dhcp4: no
      addresses: 
        - IP1/24
        - IP2/24
      routes:
        - to: 0.0.0.0/0
          via: IP1_GATEWAY
        - to: 0.0.0.0/0
          via: IP2_GATEWAY
      nameservers:
        addresses:
          - 8.8.8.8
          - 8.8.4.4
        search: []
      parameters:
        stp: false
        forward-delay: 0

Working configuration: ip -c addr
Not working (with bridge): ip -c addr

Point of this is to setup one LXC container with second IP Thank you for your help

  • Edit your question and show me dpkg -l *netplan*. – heynnema Jun 18 at 17:25
0

Does this make sense...

network:
  version: 2
  renderer: networkd
  ethernets:
    ens18:
      match:
        macaddress: 00:50:56:3e:23:56
      addresses: [IP1/24]
      routes:
        - to: 0.0.0.0/0
          via: IP1_GATEWAY
      nameservers:
        addresses: [8.8.8.8, 8.8.4.4]
        search: []
  bridges:
    br0:
      interfaces: [ens18]
      addresses: [IP2/24]
      routes:
        - to: 0.0.0.0/0
          via: IP2_GATEWAY
      nameservers:
        addresses: [8.8.8.8, 8.8.4.4]
        search: []
      parameters:
        stp: false
        forward-delay: 0

sudo netplan --debug generate # make config files

sudo netplan apply # apply new configuration

reboot # reboot and verify proper operation

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.