0

When I start up QJackctl, everything runs fine for a while (albeit with more xruns than seem reasonable), and then after a couple minutes of recording through my USB soundcard, the input sound turns into electric garble. (Not just a little distortion, more like complete ringmod garbage—maybe a cool effect, if only I could control it!) If I wait for several minutes, it returns to normal, and if I restart JACK, it returns to normal. And then it turns to garbage again.

I'm running 18.04 on a Lenovo G580. (It happened on previous versions of Ubuntu, too, but never on my former laptop.) The problem doesn't occur when I stick to internally generated sounds (like playing an audio file or midi sounds), only when I go through the USB port, which I've tried with two different sound cards (an Alesis iO2 express and a generic card), and JACK. I recently added more RAM, and that didn't help. I tried killing PulseAudio and that didn't help. Reinstalled Ubuntu and that didn't help. At first, I thought it might be a driver issue, but I don't see any other G580 users complaining.

It's as if some program that starts and stops every few minutes (maybe even runs on a schedule?) is interfering with JACK, but I haven't been able to come up with any candidates from Task Manager or the QJackctl Messages box. Any ideas what it could be or where else I could look?

Thanks. This has gone on for years now. . .

0

Turns out it's a flaky USB port. (Especially annoying that it's the double port on the left side of the laptop. It might just be a loose connection; the ports are pretty roomy.) The port next to the power cord—which I guess I didn't use because it's next to the power cord—works fine and nothing gets garbled. :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.