2

I have a VM running Ubuntu 18.04. After an upgrade (looks like it was to Kernel 4.15.0-51) I can't boot to the desktop. Instead, I see a blank, reddish screen.

If I use Grub to get a recovery mode, I can boot to the desktop just fine. I've read elsewhere that this indicates a display driver problem, but I can't find a way to install any 3rd party drivers ... I don't think VMWare needs special drivers anyway, does it?

I've modified grub to not have the "quiet" or "splash" options, but I still don't see any specific error message. I end up what might be the splash screen -- it's graphical, not a terminal window -- but it has no content.

I performed the update as usual, with the GUI "Software Updater".

The only other choice in Grub is the 4.15.0-50 Kernel. It has the same behaviour.

I eventually found a way to get the log files from a previous boot. Here's the last few things I see in the log that seem to be from before the blank screen is shown:

Jun 14 12:59:22 ubuntu16 spice-vdagent[1483]: Cannot access vdagent virtio channel /dev/virtio-ports/com.redhat.spice.0
Jun 14 12:59:22 ubuntu16 boltd[1477]: bolt 0.5 starting up.
Jun 14 12:59:22 ubuntu16 boltd[1477]: config: loading user config
Jun 14 12:59:22 ubuntu16 boltd[1477]: bouncer: initializing polkit
Jun 14 12:59:22 ubuntu16 boltd[1477]: udev: initializing udev
Jun 14 12:59:22 ubuntu16 boltd[1477]: store: loading devices
Jun 14 12:59:22 ubuntu16 boltd[1477]: power: force power support: no
Jun 14 12:59:22 ubuntu16 boltd[1477]: udev: enumerating devices
Jun 14 12:59:22 ubuntu16 dbus-daemon[955]: [system] Successfully activated service 'org.freedesktop.bolt'
Jun 14 12:59:22 ubuntu16 systemd[1]: Started Thunderbolt system service.
Jun 14 12:59:22 ubuntu16 gnome-session[1259]: gnome-session-binary[1259]: WARNING: App 'spice-vdagent.desktop' exited wit
Jun 14 12:59:22 ubuntu16 gnome-session-binary[1259]: WARNING: App 'spice-vdagent.desktop' exited with code 1
Jun 14 12:59:22 ubuntu16 PackageKit[1478]: daemon start
Jun 14 12:59:22 ubuntu16 dbus-daemon[955]: [system] Successfully activated service 'org.freedesktop.PackageKit'
Jun 14 12:59:22 ubuntu16 systemd[1]: Started PackageKit Daemon.
Jun 14 12:59:23 ubuntu16 gnome-shell[1357]: Error looking up permission: GDBus.Error:org.freedesktop.DBus.Error.ServiceUn
Jun 14 12:59:23 ubuntu16 gnome-shell[1357]: JS WARNING: [resource:///org/gnome/shell/ui/windowManager.js 1477]: reference
Jun 14 12:59:23 ubuntu16 gnome-session-binary[1259]: Entering running state
Jun 14 12:59:23 ubuntu16 xbrlapi.desktop[1569]: openConnection: connect: No such file or directory
Jun 14 12:59:23 ubuntu16 xbrlapi.desktop[1569]: cannot connect to braille devices daemon brltty at :0
Jun 14 12:59:23 ubuntu16 gsd-color[1491]: failed to get edid: unable to get EDID for output
Jun 14 12:59:23 ubuntu16 gsd-color[1491]: unable to get EDID for xrandr-Virtual-1: unable to get EDID for output
Jun 14 12:59:46 ubuntu16 dbus-daemon[955]: [system] Failed to activate service 'org.bluez': timed out (service_start_time
Jun 14 12:59:47 ubuntu16 systemd-timesyncd[664]: Synchronized to time server 91.189.89.198:123 (ntp.ubuntu.com).
Jun 14 13:04:02 ubuntu16 systemd[1]: Started Run anacron jobs.

I guess this means that grub can't figure out what it needs to know about the display driver. But I've not a clue how to fix that, or why a pushed upgrade would break it.

Any advice?

  • It's far too early to assume that you are having a display driver problem. If the new kernel does not agree with your installed system it could be a virtually unlimited number of reasons. Are you getting any particular errors? What kind of "upgrade" did you do? What exact method? What is your display adapter, anyway? Especially since this is in a container, it might be best to just skip this kernel update and revert back to the one that you know works. Boot into the new & uninstall the old. – Nmath Jun 14 '19 at 19:18
  • Thanks @Nmath ! I've made some edits to my question with the details I have. Unfortunately, I don't see any error messages -- just a blank screen -- despite my attempt to enable the display of kernel messages at boot. I haven't a clue of how to tell what display adapter I have in the VM. The host is running Windows 10 with an Nvidia GeForce GTX 970. – MikeB Jun 14 '19 at 19:40
3

I solved the problem by disabling Wayland by modifying /etc/gdm3/custom.conf:

  • Create a backup of the file:

    sudo cp /etc/gdm3/custom.conf /etc/gdm3/custom.conf.old
    
  • Open /etc/gdm3/custom.conf in a text editor:

    sudo nano /etc/gdm3/custom.conf
    
  • Uncomment the line WaylandEnable=false by deleting the preceding #

  • Save the file CTRL+O and exit CTRL+X.

  • Reboot the system.

Once I disabled Wayland, my VM is again usable on the first boot without having to use recovery mode.

This issue is being tracked as Login screen never appears on vmwgfx but installing kernel >= v4.17-rc1 (or using WaylandEnable=false) fixes it on launchpad.net.

| improve this answer | |
  • I didn't remove Wayland; I disabled it. I had to do so because it's broken. If Wayland isn't enabled, the GNOME desktop goes back to using X ... which works. It would've been hard for things to be more broken than they were before this fix. I mean, I guess I could've lost data, but my machine was certainly unusable. With Wayland disabled and GNOME now using X, I'm back to where I was before this update broke me. I'm sorry that you don't like the way that I posted my solution. – MikeB Jun 15 '19 at 22:42
  • 1
    this solution work well for me. thanks – Nicolas Jun 20 '19 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.