0

I previously used X.Org driver for my Ubuntu desktop, and my graphic card is Nvidia GTX 1070, actually I've never been satisfied with my boot time because I use an high-end SSD and the boot time always takes more than 20 s (comparing to my Ubuntu laptop which is Radeon graphics and the same SSD, only takes 9 s).

However, recently I met some problem with compatibility issue of RStudio (always crashed) and I had to change to Nvdia driver as it was described here. So the Rstudio no longer crashes, however I face a very slow boot, after entering the grub (I have dual-boot), it freezes about 30s, and then the PC has a very transient beep (shorter than the boot one), and then I had to wait another 30 s until I can enter the login.

If I run systemd-analyze, it shows:

Startup finished in 6.560s (firmware) + 6.560s (loader) + 2.848s (kernel) + 38.816s (userspace) = 54.786s
graphical.target reached after 38.725s in userspace

Does any one know how to solve this issue?

  • 1
    I dont want to sound to definitive here, but it sounds like you may be waiting on something to time out. Try to follow the instructions here which will allow to view your boot in verbose mode. I wouldnt be surprised if it turned out there was a network module or something that was actually causing the issue. If that is the case, then you will have two options: fix the error or reduce the timeout period (from like 30s to 5 or 10). Try that and report back what you see. – jwcooper Jun 14 '19 at 17:02
  • Thanks for the reply, I quite didn't understand the instruction here, so I just removed the "quiet splash" inside the /etc/default/grub, and I have seen the frozen (+10s) one is the "starting socket activation for snappy daemon"... I am now trying to find what does this mean. – Negrito Jun 15 '19 at 16:06
  • I finally sort it out, Please see my post. – Negrito Jun 15 '19 at 17:06
0

After some reseach I think I finally solved this problem, since seems like my RStudio wasn't performing properly with X.Org,so basically in the "Software & Update" > "Additional Drivers" changed to Nvidia-driver-390 (proprietary) as I used to think this is more "reliable", then I had several other problems with crashing nautilus, slow boot, etc. So then I went ot Nvidia website to check which is the proper driver, and it shows the nvidia-driver-410 (open source), once I changed to that driver, up to now I don't see any issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.