1

Upon invoking emacs, it report errrors:

Fontconfig error: "/etc/fonts/conf.d/90-synthetic.conf", line 6: invalid attribute 'version'
Fontconfig error: Cannot load config file from /etc/fonts/fonts.conf

Consult with the answer: 14.04 - Fontconfig error: cannot load default config file - Ask Ubuntu

me@alpha:~:
$ echo $FONTCONFIG_PATH
/etc/fonts

Unfortunately, it still does not work

How could solve the problem?

0

If you run the command

dpkg -l | grep fontconfig

I suspect that you find that the listed packages are not of the same version, which they should be. In that case the obvious solution is to update your system to the most recent packages:

sudo apt update
sudo apt upgrade

I suppose you are on 18.10, btw. This problem shouldn't show up on 19.04; see this bug report:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=896684

|improve this answer|||||
  • Doesn't work for me: $ dpkg -l | grep fontconfig ii fontconfig 2.13.1-2ubuntu2 amd64 generic font configuration library - support binaries ii fontconfig-config 2.13.1-2ubuntu2 all generic font configuration library - configuration ii libfontconfig1:amd64 2.13.1-2ubuntu2 amd64 generic font configuration library - runtime ii libfontconfig1:i386 2.13.1-2ubuntu2 i386 generic font configuration library - runtime Fontconfig error: Cannot load config file from /etc/fonts/fonts.conf Fatal error 11: Segmentation fault – Peter yesterday
  • @Peter: You'd better ask an own question, and provide some details on what steps resulted in that error. – Gunnar Hjalmarsson yesterday

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.