0

Currently, in Ubuntu 18.04, pressing F2 brings up a "Gnome Menu" in the top left corner.

This is not Alt+F2 or Fn+F2. It's just straight F2.

But F2 is also a shortcut in Eclipse, which I use a lot. The Ubuntu F2 overrides the Eclipse F2, losing the Eclipse functionality.

Going into Keyboard Shortcut settings, I don't see anyway to reconfigure or change or disable the F2 key. I can see options for changing Alt+F2, but not straight F2.

What do I need to know about this?


UPDATE: Screenshot of Desktop.

I forget all the widgets I've installed over the past year. Pressing F2 pops up this menu, but I can't find a settings toggle for it.

screenshot

5
  • 2
    I cant reproduce this on my Ubuntu 18.04.. F2 is not doing anything.. Alt+F2 is is asking me to enter a command.. some thing different in your situation.. I think some other settings giving you F2=Gnome Menu.. can you attach a screen shot.. what is gnome menu? do you mean when you press super+a keys.. what shows.. is that? – UnKNOWn Jun 14 '19 at 13:57
  • did you set the windows key to F2 perhaps? – Rinzwind Jun 14 '19 at 14:50
  • @PRATAP Screenshot added – Stewart Jun 14 '19 at 19:34
  • @Rinzwind The Windows key does this sort of zoom-out of all the different windows you have open. The F2 key is the one I want to work in Eclipse, but which Ubuntu is using for its own purposes. – Stewart Jun 14 '19 at 19:35
  • Related: "Disable gnome-panel launcher (Alt+F2)" – Peter Mortensen Mar 30 '20 at 19:31
1

I think you have installed gnome-shell-extenion Gno-Menu.

This menu has the F2 shortcut for "Disable Menu button shortcut key".

To access the settings options for this extension, open gnome-tweaks. If it is not installed, install it by sudo apt install gnome-tweaks. Go to the Extensions tab. Click on the Settings icon on Gno-menu.

Enter image description here

You can tick/check this option to disable the F2 shortcut for this function...

Note: While choosing this option to tick/ check... my system hanged, unresponsive. After several reboots, only this option is enabled...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.