I realize that Webex does not support Ubuntu 11, however I have a website running on my machine that I need to demo for a client and he will use webex. I need to be able to use the "share desktop" feature to do this. Is there any dependable way (gksudo, java installation, browser, anything) that lets you share your desktop?

I don't care if the audio crashes since we talk on the phone, and it's okay if it cuts out from time to time -- I just need him to be able to see it.

Alternatively, is there an easy way for me to switch to an ubuntu version that will allow me to share my desktop?

5 Answers 5


After much trial and error, I was able to get WebEx desktop sharing working in 64-bit Ubuntu just by installing a few packages:

  1. Remove unnecessary packages that cause conflicts:

    sudo apt remove icedtea-7-plugin:i386 icedtea-8-plugin:i386 icedtea-netx:i386
  2. Install 32-bit Java, a necessary 32-bit library, the Java plugin, and Firefox:

    • Ubuntu 14.10+

      sudo apt install openjdk-8-jre:i386 libxmu6:i386 icedtea-8-plugin firefox
    • Ubuntu 14.04 and below

      sudo apt-get install openjdk-7-jre:i386 libxmu6:i386 icedtea-7-plugin firefox
  3. Make sure the correct Java plugin is configured:

    • Ubuntu 14.10+

      sudo update-alternatives --set mozilla-javaplugin.so /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/amd64/IcedTeaPlugin.so
    • Ubuntu 14.04 and below

      sudo update-alternatives --set mozilla-javaplugin.so /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64/IcedTeaPlugin.so

Close and re-open Firefox, and WebEx desktop sharing should work.

  • You must use Firefox. WebEx will not work on Google Chrome as Chrome for Linux no longer works with Java.
  • If you don't remove and install the exact packages listed above, WebEx will work, but desktop sharing will not work.
  • 1
    I had webex working on 12.04, but now I switched to 14.04 I get it to almost work. Everything except the actual screen sharing works. So I go into the meeting and see the other people, but I an unable to see the shared stream. Apr 4, 2014 at 14:26
  • If I get a chance I'll test on 14.04, but in the meantime I blogged about some other methods that may work if the above doesn't: Using WebEx desktop sharing on Ubuntu 64-bit
    – bmaupin
    Apr 4, 2014 at 15:36
  • I have the exact same problem. Working fine with 14.04 but I can't see what other people is sharing.
    – jmend
    Aug 27, 2014 at 18:02
  • @balachmar I just tested these same exact steps on Ubuntu 14.04, and they worked fine. It's very important you install the exact packages as listed. I tried with many other combinations, and none of them worked. If you don't have the exact packages installed, WebEx will work but desktop sharing will not work.
    – bmaupin
    Sep 5, 2014 at 14:33
  • 1
    @Valentas I wouldn't expect this to work any more because Firefox has also removed support for the Java plugin (askubuntu.com/a/354406/18665). I'm not even sure WebEx needs Java any more with modern technologies such as WebRTC, but I'm not sure as I haven't used WebEx in years. FWIW, Wayland is not the default display server in 18.04: omgubuntu.co.uk/2018/01/…
    – bmaupin
    May 10, 2021 at 12:27

Thanks bmaupin! For me this also works on a freshly installed 64-bit Ubuntu 16.04 (no upgrade from older Ubuntu)

Enabled 32-bit support (see also: http://www.unixmen.com/enable-32-bit-support-64-bit-ubuntu-13-10-greater/):

    sudo dpkg --add-architecture i386
    sudo apt-get update
    sudo apt-get upgrade

Installed openjdk and required plugins for Firefox

    sudo apt-get -y install openjdk-8-jre:i386 libxmu6:i386 icedtea-8-plugin

Set correct Java plugin for Firefox

    sudo update-alternatives --set mozilla-javaplugin.so /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/amd64/IcedTeaPlugin.so

Run WebEx

  • Confirm all questions (trust WebEx domain, allow to use icedtea plugin, etc)
  • Screen sharing works for me
  • Audio does not yet work for me

So I've struggled with this for years, and finally have a solution.

  1. Install Ubuntu 32-bit. 64-bit simply won't work with Cisco's Webex Java plugin. I fought this for years, and finally gave up. I installed Ubuntu into a VM using [testdrive][1].
  2. sudo apt-get install icedtea-6-plugin
  3. Join a Webex and have fun sharing your desktop!

You could try ScreenLeap, which seems to have a very low setup overhead (it just downloads and runs a Java applet).


Install Oracle Java to solve this issue

Press Ctrl+Alt+T on your keyboard to open a terminal window. When it opens, copy and paste the command below and hit enter. Input your user password when prompts and it will add the PPA repository into your system.

sudo add-apt-repository ppa:webupd8team/java

After that, update package lists via:

sudo apt-get update

To install Oracle Java 8, run:

sudo apt-get install oracle-java8-installer

Change the number 8 to 6 (or 7) in the code to install Java 6 (or 7).

While installation, you’ll be asked to agree the license and then the installer start downloading Java file from oracle website and install it on your system.

To set the default Java, run:

sudo apt-get install oracle-java8-set-default

Also change number 8 to the Java version you want.

  • 2
    I tried this and audio is broken, just like with IcedTea -- "The audio device is unaccessible now."
    – eudoxos
    May 13, 2015 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.