15

I am experimenting with virtual box. One of my problems is that the mouse cursor only works within the box. How can I make it work both with the actual OS too and the virtual box at the same time?

14

Right CTRL key to release the mouse and keyboard.
Documentation on the host key is here. <-- Credit to Takkat on the link

Install guest additions for transitions without manually releasing the keyboard/mouse.

| improve this answer | |
  • right CTRL doesnt do anything. I really dont know why not. Is there a way to turn off the auto capture even before powering up the vbox? – Elysium Mar 22 '12 at 13:33
  • For me, it doesn't auto-capture without guest additions. It only captures if I click in the box. Did you set a custom host key? It should be displayed in the bottom right of the window. – RobotHumans Mar 22 '12 at 13:34
  • ty - I may have customized this some time ago. See virtualbox.org/manual/ch01.html#idp7689696 for more – Takkat Mar 22 '12 at 13:51
3

To get your mouse cursor to work, you simply need to press the Ctrl key on the right side of the keyboard. If you don't want to keep pressing Ctrl to release the mouse cursor every time, simply install the VirtualBox Guest Additions by clicking on Devices > Install Guest Additions. When you do this, you may need to mount the virtual cd-rom drive by using the following command:

$ sudo mount /dev/scd0 /mnt/cdrom

Then run the shell script to install the Guest Additions.

| improve this answer | |
  • What shell script? – Nomi Shaw Apr 10 '19 at 16:38
1

Firstly, do right+ctrl. You will be out of virtual machine then right-click on mouse sign which is down-right side on virtual machine. Disable mouse integration.

| improve this answer | |
1

This worked for me:

In the VirtualBox Manager menu at the top of your screen, go to File> Preferences> Input. Go to the Virtual Machine tab on the right. Look for Host Key Combination, then look next to it under Shortcut and delete "Right CTRL". It should now say "None."

Click OK.

| improve this answer | |
  • This did not work for me. I also could not replace "Right CTRL" after I removed it. – Steve Mar 14 at 19:56
1

I've experienced this on Ubuntu 18.04. I've found to make sure to not trap the mouse on VM boot up. Making sure to release it before mouse detection.

Also, I've set one of my VMs to Pointing Device: USB Multi-Touch Tablet and it makes my VM work with my USB mouse outside of the VM as long as I don't trap it on boot.

enter image description here

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.