1

As my title said i have some problem with configuration of nullmailer. Basicaly I have been following this website.

I have made an account on Mailchimp - where I have send succesfully the test mail. On my machine i have installed Nullmailer:

Then I have configure the remotes:

smtp.mandrillapp.com smtp --port=587 --starttls --user=ttomek.koziak@gmail.com --pass=boo

I have set the adminaddr

cat /etc/nullmailer/adminaddr 
ttomek.koziak@gmail.com

The defaultdomain remains empty

This is how my mail.log looks like:

EDIT After adding --insecure flag

Jun 13 17:06:23 tom-VirtualBox postfix/cleanup[5176]: 9A8C31A68: message-id=<20190613150623.9A8C31A68@tom-VirtualBox.home>
Jun 13 17:06:23 tom-VirtualBox postfix/qmgr[5047]: 9A8C31A68: from=<root@tom-VirtualBox.home>, size=345, nrcpt=1 (queue active)
Jun 13 17:06:24 tom-VirtualBox postfix/smtp[5178]: connect to gmail-smtp-in.l.google.com[2a00:1450:4010:c03::1b]:25: Network is unreachable
Jun 13 17:06:25 tom-VirtualBox postfix/smtp[5178]: 9A8C31A68: to=<ttomek.koziak@gmail.com>, relay=gmail-smtp-in.l.google.com[209.85.233.27]:25, delay=1.8, delays=0.45/0.09/0.67/0.61, dsn=5.7.1, status=bounced (host gmail-smtp-in.l.google.com[209.85.233.27] said: 550-5.7.1 [89.64.27.89] The IP you're using to send mail is not authorized to 550-5.7.1 send email directly to our servers. Please use the SMTP relay at your 550-5.7.1 service provider instead. Learn more at 550 5.7.1  https://support.google.com/mail/?p=NotAuthorizedError p3si308852ljp.41 - gsmtp (in reply to end of DATA command))
Jun 13 17:06:25 tom-VirtualBox postfix/cleanup[5176]: 8345A1AFF: message-id=<20190613150625.8345A1AFF@tom-VirtualBox.home>
Jun 13 17:06:25 tom-VirtualBox postfix/qmgr[5047]: 8345A1AFF: from=<>, size=2986, nrcpt=1 (queue active)
Jun 13 17:06:25 tom-VirtualBox postfix/bounce[5179]: 9A8C31A68: sender non-delivery notification: 8345A1AFF
Jun 13 17:06:25 tom-VirtualBox postfix/qmgr[5047]: 9A8C31A68: removed
Jun 13 17:06:25 tom-VirtualBox postfix/local[5180]: 8345A1AFF: to=<root@tom-VirtualBox.home>, relay=local, delay=0.32, delays=0.08/0.21/0/0.03, dsn=2.0.0, status=sent (delivered to mailbox)
Jun 13 17:06:25 tom-VirtualBox postfix/qmgr[5047]: 8345A1AFF: removed

But I do not really know where to go from this point. Any Ideas? Thanks.

  • Did you try the --insecure flag? – Jos Jun 13 at 15:04
1

So the fix was in the end quite simple.

I needed to allow less secure application access here. As well as --insecure flag in the remote file was necessary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.