4

When starting pgAdmin, I'm prompted:

Please set a master password for pgAdmin

This is a new feature of pgAdmin4 4.7: https://www.pgadmin.org/docs/pgadmin4/dev/release_notes_4_7.html

How can I disable this?

The local documentation tells me to set the "configuration parameter" MASTER_PASSWORD_REQUIRED=False, but I don't know where/how to do this: http://127.0.0.1:37059/help/help/master_password.html

7

Took me a while to find out, that's why I'm posting it here:

  1. You need to locate a file named config.py. In my case it's at /usr/share/pgadmin4/web/config.py
  2. Now create a file config_local.py (in the same folder) and enter: MASTER_PASSWORD_REQUIRED=False
  3. Restart pgAdmin server.
  4. The prompt should be gone :-)

Some reference about config files: https://www.pgadmin.org/docs/pgadmin4/dev/desktop_deployment.html#configuration

  • 1
    For anyone that needs to do this on a machine on which they don't have root access, I would like to add that you could put this file in for example ~/.config/pgadmin and then add this directory to the Python path setting in ~/.config/pgadmin/pgadmin4.conf, something like PythonPath=/home/«username»/.config/pgadmin:/usr/local/lib/python3/dist-packages:/usr/lib/python3/dist-packages – RolKau Jun 18 '19 at 21:47
  • Works on Windows too. – MarioVW Nov 12 '19 at 0:02
  • Does anyone know which directory this should be in on Windows? – James Nov 27 '19 at 22:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.