12

I have looked at previous similar questions, but still I can't make it work.

I have tried with the previous kernel (which I didn't upgrade recently btw).

In my Intel NUC8 bios the bluetooth is enabled.

But if I try to connect to my bluetooth speaker I only see this:

➜  ~ bluetoothctl
[bluetooth]# connect 00:22:37:54:51:53
No default controller available

I am not sure this could help, but I have noticed that this command

➜  ~ dmesg | grep -i bluetooth
[    3.801286] Bluetooth: Core ver 2.22
[    3.801773] Bluetooth: HCI device and connection manager initialized
[    3.801777] Bluetooth: HCI socket layer initialized
[    3.801779] Bluetooth: L2CAP socket layer initialized
[    3.801784] Bluetooth: SCO socket layer initialized
[    4.500700] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    4.500702] Bluetooth: BNEP filters: protocol multicast
[    4.500705] Bluetooth: BNEP socket layer initialized
[    5.858216] Bluetooth: hci0: command 0xfc05 tx timeout
[    5.858217] Bluetooth: hci0: Reading Intel version information failed (-110)

returns a Reading Intel version information failed (-110)

Any idea?

3
  • 3
    I've solved this by turning the power off and on again. Just shutting the pc down was not enough, though... I had to phisically detach it from the power line. I took the suggestion from here: bugs.launchpad.net/ubuntu/+source/linux/+bug/1824703 – ToX 82 Jun 13 '19 at 11:06
  • To add more strangeness to this - I simply disconnected my laptop charger, reloaded the kernel module and it started working. – John Hunt Sep 28 '20 at 9:45
  • I just needed to shut down my laptop, wait ~10 seconds, then turn it back on again. Thank you for the tips. – kas Nov 10 '20 at 1:49
2

I also resolved this by powering down my laptop, as mentioned by the question's author in a comment.

Simply restarting did not resolve the issue. To be completely paranoid, I also unplugged the machine from the power supply before powering it back on. Bluetooth magically re-appeared.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.