2

I have a Windows 10 laptop. I installed ubuntu on it and messed up the windows boot loader months ago, but ubuntu 19.04 (recently upgraded) works. I've recently started trying to fix the bootloader, and I was following the instructions here.

I ran these commands

sudo apt-get install syslinux
sudo dd if=/usr/lib/syslinux/mbr/mbr.bin of=/dev/sda3
sudo apt-get install mbr
sudo install-mbr -i n -p D -t 0 /dev/sda3

sda3 is my windows data partition. I think I misunderstood what the instructions said about "Don’t forget to replace “sda” with the Windows 10 system drive." but idk.

Now I cannot access the files on /dev/sda3 and I'm worried that even if I do fix my windows bootloader that now it won't be able to load the data!

How can I get access back to /dev/sda3 and view the files on it?

I tried:

mount /dev/sda3
mount: /dev/sda3: can't find in /etc/fstab.

And here is what it looks like in gparted: enter image description here

New contributor
Reed is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • 1
    Usually that error is from Windows fast start up, which sets the hibernation flag. Ubuntu's NTFSfix only does minor fixes & you need to run Windows chkdsk from your Windows repair flash drive if that is the issue. askubuntu.com/questions/843153/… And your show an efi partition, so would not use a BIOS boot loader like syslinux. You would need UEFI boot repairs. Many times with UEFI you can directly boot Windows from UEFI, if grub will not boot it. – oldfred Jun 13 at 3:46
  • I can access my data again now, so that part is solved, but I can't get windows to boot. What do you mean by "directly boot Windows from UEFI"? A link might help! I've used boot-repair and grub doesn't even show the windows option any more. It used to, but gave errors. I guess I probably need to post a new question about my whole boot situation. – Reed Jun 13 at 16:05
  • 1
    UEFI has a boot menu, the same key you used to boot Ubuntu live installer, often f10 or f12 but varies by vendor. Grub only boots working Windows, or Windows that is not hibernated. And fast start uses hibernation flag, so that must be off. Windows also may turn fast start back on with updates. – oldfred Jun 13 at 19:08
  • @oldfred, Thank you – Reed Jun 13 at 19:54
1

I fixed it. I think it was:

sudo apt-get install ntfsfix
ntfsfix /dev/sda3

I think that's the one that did it. Credit to https://linuxacademy.com/blog/linux/ntfs-partition-repair-and-recovery-in-linux/

https://www.thegeekstuff.com/2012/08/fsck-command-examples was of some help too, but fsck didn't get me there.

New contributor
Reed is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • 1
    Later, I broke things even worse and corrupted my entire partition table. So I downloaded testdisk and I was able to fix all my partitions with that by re-creating the partition table based upon a boot-repair log previously made. Not sure if testdisk might have worked for this problem too. – Reed Jun 13 at 16:01

Your Answer

Reed is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.