2

Basically what the title says. Apparently, gedit does not have any permission to write even on basic text files which have all the permissions needed. In fact, other IDES/text editors (such as Atom or LibreOffice) can open and modify such files without any problem. I've tried to troubleshoot but I'm unable to fix the problem. I tried reinstalling and upgrading it, but id didnt't solve the issue. Executing Gedit as sudo does work, but the point would be not to go superuser to read/write simple readme files on Documents. Worst case i think I could just use ATOM as my main text editor, but I'd like to keep Gedit for quick changes in simple text files.

For example, I'm trying to read a file called "Qiime2_notes.txt".

$ ls -l
total 36
-rw-r--r-- 1 administrador administrador   164 de ma 20 10:52 Humann-notes.txt
-rw-r--r-- 1 administrador administrador  7697 d’abr  9 11:54 notes.txt
-rw-r--r-- 1 administrador administrador   281 de ma  4 17:56 Qiime2_automation_draft
-rwxrwxr-x 1 administrador administrador 19906 d’abr  9 13:02 Qiime2_notes.txt

I try to open it with gedit:

gedit Qiime2_notes.txt

and it opens the file without any error warning, but I can't write, select or save the text.

Basically as if I hadn't got any permission to modify the text:

ss

however, when I open it with sudo gedit Qiime2_notes.txt, it works perfectly.

Now I can perfectly modify the file:

ss

however, opening it with atom Qiime2_notes.txt it works perfectly without sudo.

Any idea why is this happening?

  • Did you try running gedit from command line? For example, gedit .bashrc Is there any error message displayed? – FedonKadifeli Jun 12 at 16:06
  • And you cannot save a changed version of .bashrc??? – FedonKadifeli Jun 12 at 16:12
  • It works just as openning it from the graphical menu. it reads the document but without any permission (can't scroll, write nor save). Also typing only gedit opens a window but I can write anything, not even by opening a new file. However, non of that happens if I open it as sudo Gedit ~/Documents/sometext.txt – cblabo Jun 12 at 16:14
  • Can you try from another (possibly freshly created) Linux user? – FedonKadifeli Jun 12 at 16:15
  • 3
    Running sudo gedit some-file might change the ownership of the configuration file(s) of gedit in your home directory (root might own the file). When that happens you will have problems running gedit as the normal user ID. You can change the ownership back of {that file/those files} and make things work again. Next time, remember to user sudo -H gedit some-file; use sudo -H with GUI application programs, or some other method described at this link. – sudodus Jun 12 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.