0

I am having a serious issue installing Ubuntu 18.04 from a Rufus formatted USB drive. The installation goes fine expect when it gets to installing grub2 where the installation freezes and I need to perform a hard reset.

I am installing this on an HP Z2 desktop and I have installed Ubuntu on several other machines in the past and never had this issue. I have tried disabling fast boot etc in the BIOS menu and attempting to installer older versions of Ubuntu but to no avail.

I have also tried opening Ubuntu in the "try Ubuntu" mode and using the boot repair tool but this doesn't help either.

Before I had encountered this issue I was having another issue where the machine wasn't reading the USB drive and I was getting the following message "\EFI\BOOT\mmx64.efi - Not Found" but I managed to solve it here Can't install Ubuntu 18.10 on XPS 15 - EFI\BOOT\mmx64.efi not found.

The workaround that I used involved going into EFI/BOOT and making a copy of grubx64.efi and renaming it as mmx64.efi so I don't know if this is part of the problem? But the grubx64.efi file is still there and if I don't do this then I can't start the installation.

Any help that could be provided would be greatly appreciated

  • youcan't write changes to the EFI partition? it's read only? what's the current state? – tatsu Jun 12 at 11:43
  • Sorry I'm not sure that I understand the question. I meant that I made changes to the USB drive that I am using to make the installation so it is just the rufus formatted drive that I am changing the file grub264.efi to mmc64.efi – sb94 Jun 12 at 12:01
  • what? why? don't do that. of course that won't work. It looks like a hyberfile lock issue to me but I could be wrong. – tatsu Jun 12 at 12:04
  • The reason I did this is because it won't boot at all and I can't even run the installer without this fix. I had the same issue encountered here askubuntu.com/questions/1085550/… – sb94 Jun 12 at 12:07
  • 1
    Unfortunately no. opted to erase the disk during my installation because I only wanted to use ubuntu – sb94 Jun 12 at 12:35
1

Hey people with a HP Z2 and the same problem as above:

Upgrade your firmware to the latest version and Ubuntu 18 and GRUB 2 will install just fine on a UEFI system and secure boot turned off

Legacy disable secure boot disable

For me, the online update tool in BIOS would not work, I had to manually update the firmware with a memory stick.

Hope this helps someone with the same problem.

New contributor
Christian Tucker is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.