0

I am becoming quite frustrated with my internet connection on my Ubuntu 18.04.2 xfce. The connection is quite unstable at times, symptoms are variable speeds and drop outs. when the instability appears I can ping google (for instance) & run speedtest-cli but web pages take ages to load or time out all together. I need to turn network off then on again to regain connection. I have done the network manager & networkd thing. Here is my network card from lspci: Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 09) Subsystem: ASUSTeK Computer Inc. P8 series motherboard Flags: bus master, fast devsel, latency 0, IRQ 43, NUMA node 0 I/O ports at d000 [size=256] Memory at d0004000 (64-bit, prefetchable) [size=4K] Memory at d0000000 (64-bit, prefetchable) [size=16K] Capabilities: Kernel driver in use: r8168 Kernel modules: r8168 I have done study and tried both r8168 & r8169 drivers/ kernel module combinations. Machine basics are AMD FX-6300 6 core processor, with 8G ram. The ethernet controller is on the motherboard. Any assistance would be most welcome as I am tearing my hair out here. Oh, by the way my router is too far away for direct hard wire so i have a wifi to ethernet device (Dlink DAP1360) to derive my connection.

  • can you reproduce the symptoms on windows? – tatsu Jun 12 at 11:11
  • Don't have access to windows I'm afraid. I have tried several browsers (Palemoon, Chrome, Chromium) and on another OS (MX Linux) which I have as dual boot on my box. I also tried from Manjaro on virtualbox but of course the virtual network is still using my physical network. Thanks for your comment. – Magoo Jun 13 at 5:32
  • well if you can't rule out the ISP or network quality, it's seems like jumping to conclusions to blame ubuntu, no? – tatsu Jun 13 at 8:07
  • I hope it didn't sound like blaming Ubuntu, I do actually suspect network quality or ethernet device, but just needed some guidance to help isolate things. – Magoo Jun 14 at 9:29
  • 1
    OMG! what a mission to create a bootable windows flash drive with Ubuntu. Ended up using Rufus on a windows virtual machine. I now have a bootable usb device ( have started install to test it, then aborted) will start full install very soon. – Magoo Jun 16 at 10:38
0

try reinstalling ubuntu or testing it on a windows to see if that fixes the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.