0

Some background about the issue - I have Dell XPS 13 9370 which I am trying to double boot with Ubuntu and windows. Initially there was a problem that Ubuntu wasn't detecting my ssd, which I solved by switching from RAID to AHCI. But now when I tried to boot with USB. It first got stuck on the loading screen, then I think I pressed one of the arrow keys and then it landed on a black screen with bunch of stuff written on it, some of it were -

assertion 'G_UDEV_IS_DEVICE (device)' failed A connection to the bus can't be made Repeat this process for the rest of the CDs in your set.

(I wasn't able to add a picture so I wrote some of the lines)

initially I was able to get till the part where we need to create partitions which was not recognizing my ssd. After changing from RAID to AHCI, this new problem has occured.

Could someone help me to solve this issue? As one could guess I am a beginner , so a step by step procedure would be very helpful. Thanks in advanced.

UPDATE: I used another USB drive to check if there was a problem with the previous one , now I have a new error. It says 'a start job is running for holds snappy daemon refresh(23s/no limit)' and several others lines showing different errors. No idea what's going on!

  • 1
    hmm why don't you start again : this time use rufus.ie use the dropdown menus to select (1) UEFI only, and (2) GPT. then create the USB key. make sure to use a ubuntu 19.04 iso downloaded from ubuntu.com then before trying to boot to the usb key, go into a powershell run as an Administrator and type powercfg -h off then when you reboot go into the BIOS and change the boot priority to have "USB - UEFI" or equivalent as the first (it's important that it says UEFI or EFI.) then boot to it, select "try ubuntu", then once you get to the desktop you can run the install ubuntu. – tatsu Jun 11 at 13:12
  • I did the whole process again using a different usb,using Rufus, basically following the Ubuntu tutorial (tutorials.ubuntu.com/tutorial/…). I used 18.04.2 LTS and MBR instead of GPT. will using GPT solve this thing? The other changes you mentioned, I have done it apart from changing the boot priority, I select USB option from the quick boot menu and it comes under UEFI as you mentioned. Thank you for your reply. – Tarun Gupta Jun 11 at 13:50
  • In above tutorial it was mentioned to use MBR , so I used it , I don't know the difference between the two, I will GPT a try if you think it works. Thanks again – Tarun Gupta Jun 11 at 13:55
  • I will use GPT and let you know if it works. – Tarun Gupta Jun 11 at 13:56
  • 1
    It finally worked ! I guess using GPT instead of MBR did the trick. Thanks a lot tatsu, you saved my day !!! Thanks again 😊 – Tarun Gupta Jun 11 at 14:39
0

You should be using Rufus to create your installation medium.

be sure to configure it to use GPT and UEFI :

rufus configured in GPT and UEFI mode

leave it on Fat32

and things should run much more smoothly from there.

ideally, before rebooting to the ubuntu USB and installing, open up a powershell run as Administrator and type:

powercfg -h off

this will ensure hard drives are shutdown correctly and that they can be written to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.