0

I'm running a fresh installation of Ubuntu 16.04. I installed it a two days ago, and it was working perfectly. Yesterday I rebooted my PC and booted into my other OS (Windows 10) finished up some work, and this morning I started my PC and booted into Ubuntu, but it doesn't load. It shows the ubuntu logo and the 5 dots underneath it, and the dots start changing color as it's loading, but freezes at the same point and it just hangs there.

enter image description here

My setup is two separate SSDs, one is for Windows 10 and the other for Ubuntu. No other drives were present in the system during the installation process. GRUB should be on the SSD which has Ubuntu.

Edit 1a: I tried adding the nomodeset string while booting, no changes.

Edit 1b: One thing i might mention is that i my gnome shell was locked to a older version (think it was the default for 16.04lts) and i couldn't install anything from the gnome-shell extension for firefox (it kept saying not GS is installed) so i did the following

sudo add-apt-repository ppa:gnome3-team/gnome3
sudo add-apt-repository ppa:gnome3-team/gnome3-staging
sudo apt-get update
sudo apt-get dist-upgrade
1

Press Esc whenever you have the chance while there's animation on that screen, it'll go in text boot mode where you might be able to catch what's causing the issue.

maybe there's a hanging job or something.

| improve this answer | |
  • i tried pressing ESC, no affect sadly – lordZ3d Jun 11 '19 at 9:36
  • then you might want to boot into recovery mode - use grub to navigate into advanced options and then choose the latest kernel with recovery option, make sure you're connected to the internet, do a purge for gnome and ubuntu-desktop(optional) and then try to reinstall them.. first check what packages that might be causing the freeze, could be your graphics card for instance or just gnome as a whole, broken. so do a apt-get purge --remove <package1> <package2> etc.. and then do apt-get autoremove && apt-get autoclean && apt-get clean then reinstall gnome and the packages you just purged – Viktova Jun 11 '19 at 13:09
  • Thanks for the help but i managed to fix the issue i'll post the answer soon – lordZ3d Jun 11 '19 at 13:22
0

The error was a start job is running for hold until boot process finishes up This was caused by the Edit 1b form the OP.

I solved this by:

  • booting into recovery and choosing "drop to root shell"
  • sudo apt-get remove plymouth && sudo apt-get remove xserver-xorg-video-intel
  • sudo apt-get install -f --reinstall lightdm
  • sudo dpkg-reconfigure lightdm
  • sudo apt-get install gnome
  • sudo apt-get autoremove

Working well now.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.