I am using Libre Office on Ubuntu 18.04 and I cannot get spellchecking to work. When I follow the suggestions for earlier releases of Libre Office they do not work. Specifically I click on Tools/Language/For All Text in Writer it does not show any language as selected. So I click on English Canada and the menu item closes immediately. When I click on For All Text again the menu item still does not show English Canada as selected. I would show a screenshot but libreoffice interferes with the keyboard shortcuts for taking a screenshot. I NEED to select the language in order for spellcheck to work so how do I convince LibreOffice to use the language I am trying to select?

Manage languages under system settings shows both English Canada and English US as installed System Language Settings

I have tried to follow the suggestion to select a bit of text and then go to Tools/Language. This discussion does not permit including images in comments so I am putting the resulting image here:

enter image description here

I cannot select ANY of the languages in the selection list for Text Language. When I do the dialog immediately re-displays [None].

enter image description here

And the System Language management dialog says:

enter image description here

I am getting desperate. I really need to know how to get spell checking working on this system. How do I attract the attention of somebody who has actually worked on this code?

I am looking deeper into the hierarchy of dialogs: At Tools/ Language/ More I see:

enter image description here

Note that I am so desperate to get any kind of spellcheck that I have switched the default system language to Amurikan. UND IT STIL WIL NOUGHT CHEQUE MI SPELIN.

I am also annoyed that the date acceptance pattern is invalid for Canada. Outside of the Excited States of America nobody on the entire planet uses M/D/Y! In Canada we prefer D/M/Y because that is the order used both in British English "4th of July 1776" (Since GW and his friends all spoke British not American) and in French "le 4 Juillet 1776".

  • With something typed in and you then go Tools > Spelling what Text language is shown?
    – doug
    Jun 17, 2019 at 5:15
  • That dialog shows Text Language empty. If I try to explicitly select Canadian Engish my request is ignored and the selection says [None]. How do I get Writer to pay attention to what I have specified? Jun 19, 2019 at 20:25

2 Answers 2


I had exact same issue and the default settings did not work for me. This worked for me. Even hunspell or myspell, as suggested by resplin, didn't work.

However adding this extension to Libre Office worked like charm: https://extensions.libreoffice.org/extensions/english-dictionaries/

You'll need to go to Tools > Extension Manager > Add > {upload extension file}. Restart.

  • It was the restart that worked for me. tks
    – X Tian
    Jun 22, 2020 at 12:00

Install the Hunspell library for Canadian English:

sudo apt install hunspell-en-ca

Then configure LibreOffice to use it:

Tools -> Options -> Language Settings -> Locale setting -> English (Canada)

Tools -> Options -> Language Settings -> Writing Aids -> Available language modules: Hunspell SpellChecker -> Edit -> Language: English (Canada)

  • 1
    It would be nice for Canadians to have the flexibility of UK English and American English loaded at the same time. After all it kind of is a hybrid country in language (plus other areas). Jun 11, 2019 at 2:10
  • @WinEunuuchs2Unix don't forget French Canadians :)
    – graham
    Jun 11, 2019 at 5:56
  • $ sudo apt install hunspell-en-ca [sudo] password for jcobban: Reading package lists... Done Building dependency tree Reading state information... Done hunspell-en-ca is already the newest version (1:2017.08.24). 0 upgraded, 0 newly installed, 0 to remove and 45 not upgraded. Jun 17, 2019 at 3:24
  • I would like to include a screenshot to show that I definitely HAVE installed and activated canadian english but Writer is NOT doing any spell checking. Jun 17, 2019 at 3:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .