2

I downloaded Ubuntu Server 18.04.2 (classic installer) and put it on a flash drive. I then ran the integrity check and all was well. But then I realized that I wanted to install the HWE kernel. After selecting HWE kernel, the installer start screen reloads, and I wondered if I would get a different result if I ran the integrity check with the HWE kernel.

Turns out it did, and the EFI.img file failed the MD5 check. ./boot/grub/efi.img file failed the MD5 checksum

I double checked the SHA256 of the iso I used to burn the USB (made with USB creator), and it was fine, so I figured I must have a bunk USB stick. I tried another stick (this time using dd copy method) and got the same problem. I then tried a third USB stick of a different brand (again using dd), and still the same.

So is there a problem in the installer itself? Or does the exact same file keep getting corrupted every time I try to create the bootable USB?

Three times in a row!

Edit: Ok, now I am really confused. It seems that efi.img file becomes corrupted at some point during the check. Here is a sequence of shots to illustrate:

  1. I booted from the UEFI partition of my USB drive (oddly, on all the USB drives I have made today, there are two UEFI partitions seen by the BIOS, not sure if this is relevant).
  2. Next I ran the integrity check in the main menu: integrity check #1 it passed: all seems well
  3. Then I went into the HWE kernel and tried the integrity check from there, which failed (the original reason for this post). select HWE kernel no bueno
  4. Then this is the real kicker.. now when I run the integrity check from the main menu, I get the same error!! Did the act of doing the check somehow cause corruption? back at the main menu WTF?!

And one other thing: What is the "classic" keyboard based installer called officially? I don't know what to file the bug under since it doesn't seem to have a handy name like "Subiquity".

Update: If I select sandisk instead of sandisk: uefi partition, that does a legacy boot with a different looking main menu. However then I cannot create UEFI partitions in the manual partition editor. Perhaps the EFI section is in use to boot the usb and that is why checksumming fails? Is the classic installer even maintained anymore?

7
  • The old 'alternative' version has the Debian text mode installer, and does not provide a live system, only a direct installation. Maybe there is a bug related to the HWE. Does it work to install the standard way (with the first option 'Install Ubuntu Server')? In that case you might be able to upgrade after installation to the new kernel and its HWE. – sudodus Jun 10 '19 at 17:24
  • Not if I have first tried using HWE. After that the file is corrupted when in either UEFI or BIOS mode. But I just re-made the USB from scratch and am trying that approach. If it is a bug, where do I report it? Does the classic installer even have an official name? – Stonecraft Jun 10 '19 at 17:30
  • Did you check that the iso file was downloaded correctly (with md5sum)? Is it necessary to boot your server in UEFI mode? – sudodus Jun 10 '19 at 17:30
  • 1
    I don't know the name of the classic installer. Let us hope that someone who knows will chip in and help you. – sudodus Jun 10 '19 at 17:31
  • 1
    @sudodus installing HWE kernel later did indeed allow me to get my desired installation. But yeah I will have to file a bug report about the HWE integrity check "corrupting" efi.img – Stonecraft Jun 10 '19 at 19:29
1

After a dialogue via comments the original poster, @Thoughtcraft, could work around the problem:

Installing the standard way (with the first option 'Install Ubuntu Server') works, and it is possible to install the HWE kernel later to get the desired Ubuntu Server system.

1
  • Yeah, I still am curious whether that file was actually getting corrupted or not.. Maybe I'll find time to file a proper bug report. – Stonecraft Jun 11 '19 at 4:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.