31

I installed the latest updates from the software update center today (I update when ubuntu displays a notification), restarted the machine and now it's unable to boot properly. The best screen I can get is displayed below. If I resize the screen then it goes to black. If I restart the machine then it displays just purple.

The screen I get after updating ubuntu

Note that the screen is unresponsive, I can't click anything on it.

Other than SMBus Host Controller not enabled! I don't see any other warnings. Note that I don't know if this warning existed before the update.

I'm running ubuntu 18.04 in vwmare workstation 15 player (latest update). Any ideas on how to begin debugging this?


Update: Trying to boot Ubuntu, with Linux 4.15.0-50-generic instead of Ubuntu, with Linux 4.15.0-51-generic didn't help.

Update: Blacklisting i2c-piix4 according to this answer didn't remove the warning or fix the issue.

Update: Blacklisting i2c-piix4 according to this answer removed the warning but didn't fix the issue.

Update: The answer from Uzair helped me log into the account (run dpkg and update grub from recovery mode).

Answer: This answer helped me fully to resolve the issue. I don't understand the fix. If anyone does, put it as the answer and I'll mark it as such.

Regarding duplicity: The answer from another question did solve my issue but I don't think my question is a duplicate of that one. I began with a fresh install of 18.04 a few months ago, did several updates without an issue and only today experienced issues which are different than those described in the other question. I think we experienced different bugs with wayland and we both solved it by disabling it which is a destructive solution applicable to many questions.

52

The issue is with Wayland. While Ubuntu defaults to an X11 session, for some reason they left it enabled for GDM.

You can certainly replace GDM with LightDM, but an easier option would be to:

sudo nano /etc/gdm3/custom.conf

Then change the line:

#WaylandEnable=false

to

WaylandEnable=false

Press Ctrl+O and then Ctrl+X and reboot. If you don't wish to reboot you can do

sudo systemctl restart gdm

Which will restart your windows session (this assumes ssh into the box to fix as above).

| improve this answer | |
  • 2
    thanks this worked for me. spent hours and frustration trying to fix it. wish I found this. to help others googling /vmware player ubuntu hangs on purple screen barely visible ubuntu logo after update. – Dreaded semicolon Jun 13 '19 at 5:24
  • 1
    Thank you for this answer! It fixed it for me. Really saved my day! ^^ – Kulgar Jun 13 '19 at 9:51
  • Man, you're a live safer! Thanks so much for this! Made my day! – LukeFilewalker Jun 24 '19 at 18:46
  • 3
    You don't need ssh login. You can also reboot the machine - hold shift on start up (with VMware Player as the active window). Select recovery mode, root shell. Follow instructions above. sudo reboot. – technogeek1995 Jun 26 '19 at 16:03
  • This did worked for me. Thanks – Kishore Kumar Jul 17 '19 at 17:58
5

I had the exact same problem. I somehow fixed it but I have the same screen as in your screenshot after restarting.

I did the following:

  1. Booted Ubuntu in recovery mode. (Long press Left Shift to show the menu while OS is booting).
  2. Then I have selected to "Repair broken packages"
  3. Then I have selected "Update grub bootloader
  4. Finally, "Resume normal boot"

Edit: I have installed "LightDM" and the problem is gone. Looks like there was an issue with "GDM3".

Voila! I have the login screen displayed was able to login. But restarting brings the problem back to square one. Could it be a problem related to Display/Graphic settings?

| improve this answer | |
  • Your steps helped me to boot the machine but I can't get the screen to full size. When I click enter full screen mode in vmware the screen goes black. – Spidey Jun 10 '19 at 11:40
  • 1
    I managed to get everything working with this answer askubuntu.com/a/1079363/209738. I have to admit I don't fully understand the fix (xorg, wayland and etc.) but it helped. I can restart and resize my screen just as I used to. But your hint for GDM3 helped me find it. – Spidey Jun 10 '19 at 11:49
  • Holding the shift key on a desktop machine does not bring up the GRUB menu to get to the safe login. I accidentally found out that I had to left click the mouse while pressing the shift key. It took me several hours to stumble on that. – Steven Greenberg Jun 20 '19 at 2:37
  • I think your mouse click is giving vmware focus. Without focus the shift button isn't making it into your VM. – russau Jun 21 '19 at 21:27
0

I searched all over since the the xorg screen initialization was failing and couldn't find any answers - So I looked in VSphere and the Video was set to 1 card and 4MB RAM. - It worked in Ubuntu 16, but not 18. - Changing the video to Auto solved the problem. (combined with the Wayland change)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.