0

I'm running Ubuntu 19.04 and installed Nvidia proprietary drivers. However, after installation, once I reboot, the boot process gets stuck just before the display manager kicks in (probably when it is being initialized). After Googling, I discovered there's a known issue with Nvidia drivers and Wayland and that a fix was to disable Wayland by editing the gdm3 config file. I tried this, hoping it would solve my problems but it didn't. I continued facing the same problem.

Thinking the issue lied with the Nvidia driver itself (I initially tried nvidia-driver-418, I rollbacked to 390). However, the issue persisted. Seeing as the problem ultiamtely lied with gdm3 I even tried installing lightdm. Even this didn't fix the problem.

The interesting thing, however, is that if I skip the login screen by logging in through a tty shell and then starting xorg using startx, I'm taken to the desktop without any issues.

Is there any way I can fix this issue? Would switching to a different DE and DM work?

Thanks.

EDIT: 'lightdm' doesn't work either. I have it as my default DM but the issue still persists. The last two lines of the debug messages during boot are as follows (before the boot process hangs up)

Start Light Display Manager

Start Wait until snapd is fully seeded

It is after Wait until snapd is fully seeded that the system hangs. However, I am able to drop into tty1 by modifying grub parameters and then start xserver from there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.