0

I have an Asus monitor for a 2016 XPS 13 developer edition laptop. I've been trying to get the resolution to look better than the defaults. I ran the following xrandr commands:

xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode DVI-I-1-1 "1920x1080_60.00"

Afterwared I changed the settings in the GUI manager. The screen looks much better but the edges overflow past the monitor edges. Is there a good way to fix this? The monitor I am using is:

https://www.amazon.com/ASUS-MB169B-1920x1080-Portable-Monitor/dp/B00FE690DI/ref=sr_1_3?keywords=portable%2Bmonitor&qid=1560014011&s=gateway&sr=8-3&th=1

Edit: I forgot to mention that I am running Ubuntu 19.04.

  • 1
    You can't magically change the monitor's physical resolution of 1366x768 pixels to 1920x1080 pixels. – danzel Jun 12 at 17:42
  • 1
    The Amazon link you provide is a bit ambiguous. Are you running the ASUS MB168B, or the ASUS MB168B+? The resolution of these monitors differs. Only the latter will support 1080p resolution. – richbl Jun 13 at 4:27
1
+50

Use the auto adjust on your monitor by going to its menu and choosing: LCD Monitor TroubleshootingPicture or Text blurDisplay Position or Resolution not correctScreen color is abnormal or random jitter

  1. Automatic calibration (Auto Adjust): Press and hold the SPLENDID key for about 4 seconds for automatic correction.

    Note¹: Auto Adjust is valid only when the input is an analog signal (VGA).

    Note²: Not every model has an Auto Adjust hotkey.

  2. Please adjust the current resolution to the correct setting and refresh rate according to the different sizes in the below table:

    Ratio   Size    Resolution   Refresh Rate
    [4:3]      17"  1280x1024     60Hz  
    [16:9]  23-46"  1920x1080     60Hz
               65"  1920x1080    120Hz  
    [16:10]    20"  1680x1050     60Hz
               24": 1920x1200     60Hz  
    
  3. Update the graphic card driver:
    My monitor cannot display proper resolution

  4. Monitor Reset: Back to the initial value of display: Hold down the MENU key and select MENUSystem SetupResetYes

  5. Check if the signal cable ( VGA / DVI / HDMI / DisplayPort / USB) is firmly seated and confirm the other end of the output cable has been firmly seated to the computer input port (graphics card). Unplug and plug 2-terminals again and make sure none of the pins are bent.

Source

1

I'd like to refer you to this answer : https://askubuntu.com/a/973582/307184

as anticipated, given the name "X" render, xrandr is incompatible with Wayland.

given Wayland is the default session on ubuntu 19.04 you cannot use xrandr (which is obsolete as 19.04 solves most to all display issues and comping with a more complete multi-monitor configurations menu built-in)

Basically your monitor is already at the correct resolution from a PC perspective and the only additional changes you can make must be found in the monitor setup itself (E.G. turn "overscan" off)

  • I assume in 19.04 you can change from Wayland to Xorg like you can in previous versions? – WinEunuuchs2Unix Jun 14 at 23:42
  • I suppose but I don't think you'd really want to : maketecheasier.com/whats-new-in-ubuntu-19-04 this articale says there's no scaling for example with xorg. – tatsu Jun 15 at 12:23
  • You already said 90% of what I was going to say so +1 and an edit but feel free to ping me in chat and/or revert the edit if you disagree with the addition. ;-) – Fabby Jun 17 at 21:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.