3

I am using the Lenovo Thinkpad e490. I installed dual-boot with Windows, but I had a couple of issues so I updated my Kernel to 5.0.13 (I read in a forum that this version fixes some problems, but newer versions are probably fine too). Now I did some speed test and realized that my CPU is slower then it should be. So I tried to set the CPU governor to performance using cpupower. But somehow it isn't installed. When I type cpupower in the terminal i get:

WARNING: cpupower not found for kernel 5.0.13-050013

You may need to install the following packages for this specific kernel:
    linux-tools-5.0.13-050013-generic
    linux-cloud-tools-5.0.13-050013-generic

  You may also want to install one of the following packages to keep up to date:
    linux-tools-generic
    linux-cloud-tools-generic

All of these packages mentioned are not found when I try to install them with sudo apt-get install <packagename>.

When I run sudo apt-get install cpupower I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package cpupower

Is there another way to change the CPU governor and is cpupower really not supported for all kernels?

I also tried several other kernels with the same problem.

3
  • There is no need to use any tool type program at all. One can just use the basic primitive commands to change the settings. However, the best answer for your needs depends on your default CPU frequency scaling driver, which, in turn, can be processor or kernel command line dependent. Please edit your question adding the output for these two commands: cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver and cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor . Jun 9, 2019 at 16:15
  • I was able to change the cpu gov by following the advice in this thread: askubuntu.com/questions/20271/…
    – Paul_W
    Jun 10, 2019 at 9:29
  • It would be nice if you gave the command to people who do not know how to set it Feb 15, 2020 at 12:36

2 Answers 2

0

I am not sure if this could help, but I had the same message when installing cpupower E: Unable to locate package cpupower I ve read on ubuntu packages site that its requirement was linux-tools-generic, so I successfully installed it. However upon starting it I had that message above it needed it for a different kernel, so I also installed the listed suggestion for my kernel linux-tools-5.0.13-050013-generic. So maybe first installing a generic library linux-tools-generic helped to propel the installation forward with a more specific kernel package, unless you also miss some repositories configurations and libraries in them. I have added Bionic repos to my fossa repos, though I still experience many issues locating various packages as I have installed a slim version of ubuntu if that could be the case perhaps.

0

Try to install linux-tools for your core name.

sudo apt-get install -y linux-tools-common linux-tools-$(uname -r)

Or run

uname -r

it returns (for example) 5.11.0-44-generic And you install your version

sudo apt-get install -y linux-tools-5.11.0-44-generic

look answer https://unix.stackexchange.com/questions/341927/how-to-install-cpupower-on-ubuntu-14-04-kernel-4-6-0

1
  • I am receiving the error " Unable to locate package linux-tools-5.13.0-52-generic "
    – Corky
    Jul 8 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.