0

Question relates to: Chromebook 15 Acer model CB3-532 Braswell

With write protect screw removed I performed full BIOS flash. Replaced write protect screw. Installed Ubuntu 18.04 as the only operating system.

Laptop is fully operation apart from sound which worked fine before BIOS flash.

I only get Dummy Output.

lspci
00:1b.0 Audio device: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio Controller (rev 35)


aplay -l
karta 1: chtrt5650 [chtrt5650], urządzenie 0: Audio (*) []
  Urządzenia podrzędne: 1/1
  Urządzenie podrzędne #0: subdevice #0
karta 1: chtrt5650 [chtrt5650], urządzenie 1: Deep-Buffer Audio (*) []
  Urządzenia podrzędne: 1/1
  Urządzenie podrzędne #0: subdevice #0


dmesg | grep -i snd
[    3.936277] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    4.444225] cht-bsw-rt5645 cht-bsw-rt5645: snd-soc-dummy-dai <-> media-cpu-dai mapping ok
[    4.444267] cht-bsw-rt5645 cht-bsw-rt5645: snd-soc-dummy-dai <-> deepbuffer-cpu-dai mapping ok


cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                  HDA Intel PCH at 0xd1314000 irq 315
 1 [chtrt5650      ]: chtrt5650 - chtrt5650
                  GOOGLE-Banon-1.0-Banon

Tried so far:

1) set /etc/modprobe.d/alsa-base.conf to

options snd-hda-intel model=intel-x58

and

options snd-hda-intel model=auto

and

options snd-hda-intel model=acer

and

options snd-hda-intel model=generic

All options no sound. The last one actually showed HDMI/DisplayPort which might be avenue to follow but I do not know how?

2) sudo apt-get install oem-audio-hda-daily-dkms following sudo apt-add-repository ppa:ubuntu-audio-dev/alsa-daily

No change.

3) This seams related: https://github.com/GalliumOS/galliumos-braswell/blob/master/usr/share/alsa/ucm/chtrt5650/chtrt5650.conf This cards shows as 5650 or 5645 I am not sure what this means but following suggestion in the answer I tried:

3.1) downloaded files: github.com/GalliumOS/galliumos-braswell/blob/master/usr/share/… and github.com/GalliumOS/galliumos-braswell/blob/master/usr/share/…

3.2) put them as /usr/share/alsa/ucm/chtrt5650/chtrt5650.conf and /usr/share/alsa/ucm/chtrt5650/HiFi.conf (it was necessary to create chtrt5650 folder as it was not there before)

3.3) Rebooted and: No change. Dummy Output still as the only sound output device.

  • With this same laptop I have sound from GalliumOS 3.0 "Braswell" ISO. Did you use stock Ubuntu? – rik-shaw Sep 12 at 8:59
  • Yes. Standard install of Ubuntu. – berduchwal Sep 13 at 10:07
0

Try downloading that file and the HiFi.conf (https://github.com/GalliumOS/galliumos-braswell/blob/master/usr/share/alsa/ucm/chtrt5650/HiFi.conf) and put them in /usr/share/alsa/ucm/chtrt5650/chtrt5650.conf and /usr/share/alsa/ucm/chtrt5650/HiFi.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.