I have a Seagate 5tb external hard drive I use for storing various media. Today, I plugged it into Xubuntu 19.4. The drive made a few 'grating' sounds, the light indicating it is working came on, but Xubuntu cannot see the drive.

It does not register in Thunar, and sudo fdisk -l does not display it.

Update 01:

Changing the USB slot I use, and typing sudo fdisk -l again output the message:

Partition 1 does not start on physical sector boundary.

Update 02:

Yesterday evening, sudo fdisk -l stopped reporting the presence of the external HDD.

Today, sudo fdisk -l hangs while trying to read the external HDD and I seem not to be able to end the task (ctrl+c does not exit).

However, Thunar sees the presence of the drives, but cannot seem to mount them. I clicked on one of the partitions on the external HDD and now it is trying to mount, and so wont let me unmount either!


found another issue which looks like it might be a similar problem, but I am not sure what advice to follow in the link which pbhj provided.

Update 03:

If I plug the external HDD into a USB slot, then unplug it, it also appears that the USB slot gets 'turned off' by my laptop. Plugging in a mouse shows the mouse does not work, and other USB drives do not work anymore in the drive.

Can anyone help in diagnosing this issue?

  • Maybe someone can help you, if you post the output of "dmesg". – Yeti Jun 7 at 14:43
  • I suspect something happened, probably corruption. If it has NTFS partition or partitions you may be able to correct it with Windows error correction tools. – GabrielaGarcia Jun 7 at 15:15
  • Hi guys. Thanks for joining in. The external HDD is formatted to ext5. Dmesg to follow -- it generated a lot of output! – bryncoles Jun 7 at 19:16
  • Ok, I put the Dmesg into a pastebin, since there was a lot of it and I am not sure what's needed. it can be found at: [pastebin.com/6Z7vkL0U ] – bryncoles Jun 7 at 19:24
  • Looks like a dupe of askubuntu.com/questions/862664/…, same "DID_ERROR", etc. – pbhj Jun 7 at 21:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.