1

I was trying to set my Ubuntu to disable touchpad when I'm typing, but no success.

I'm using Ubuntu 19.04 in a Dell Inspiron 7000 laptop.

Already set the option in gnome tweaks, but no effect. Already use the syndaemon -i 1 -d -t -K option and still no effect.

Googling my problema I've found this How can I disable touchpad while typing? On Ubuntu 16.04 syndaemon isn't working, but it seems no apply to me, since the xinput list resultas are no two drivers:

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PixArt USB Optical Mouse                  id=12   [slave  pointer  (2)]
⎜   ↳ DELL0828:00 06CB:7E7E Touchpad            id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Elite Silicon USB Audio Device            id=11   [slave  keyboard (3)]
    ↳ Integrated Webcam: Integrated W           id=13   [slave  keyboard (3)]
    ↳ Intel HID events                          id=15   [slave  keyboard (3)]
    ↳ Intel HID 5 button array                  id=16   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=17   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=18   [slave  keyboard (3)]

So here I'm with a crazy touchpad jumping when I'm typing some texts. Can you help me with this?

2
  • 1
    Check whether you are using libinput, and not the older synaptics drivers: dpkg -l | grep synaptics should give no output, whereas dpkg -l | grep libinput should give a list of installed packages. If using synaptics, then try moving to libinput because that will expose more options in the Mouse and touchpad settings. – vanadium Jun 7 '19 at 13:00
  • @vanadium this worked like a charm. Thank you. – Renan Andrade Jun 11 '19 at 19:39
1

The Vanadium comment in my question was the best solution to my issue. I'd two drivers. After remove Synaptics the problem gone.

0

Touchpad-Indicator is probably the best. Get it here. Note that for 19.04 you have to install a special version (until they update Touchpad-Indicator) that can be found here.

Toggle Touchpad is a good alternative, and it can be found here.

0

vanadium comment's at Disabling touchpad when typing led me to wonder if I had two drivers installed on my Ubuntu 19.04 LTS installation (a laptop by System76 called Oryx Pro). I don't given the readouts below. However, heynnema's answer at https://askubuntu.com/a/1149384/340383 mentioned 19.04, which matches my installation, so was wondering if the Touchpad-Indicator "special version" is needed. It turned out that, in my case for my hardware, it was not needed (might still apply for the OP's hardware, though). (I'm shy of using special versions of packages as I know I'll forget to reapply them upon each new Ubuntu upgrade).

The solution for me turned out to be the answer at https://askubuntu.com/a/1090080/340383 which is to use syndaemon -i 0.5 -t -K -R with no further adjustment. syndaemon was apparently installed by Ubuntu's default installer, and thus did not require me to install any package beyond the default.

I tested this out by having my wife repeatedly tap the touchpad while I was furiously typing, and confirmed that with the syndaemon running, the mouse click events did not get detected, but without it, the mouse clicks did make their way into the system, wreaking the extremely annoying havoc mentioned by the OP. So now I speculate that the OP's DELL0828:00 06CB:7E7E Touchpad hardware, that xinput shows, might be the problem-child here, not the SynPS/2 Synaptics TouchPadone whosesyndaemonfix seems to be more applicable to (givensyn` in the name of the executable).

Details of my hardware and config:

$ synclient -l | grep PalmDetect
    PalmDetect              = 1
$ dpkg -l | grep libinput
ii  libinput-bin                               1.12.6-1                                           amd64        input device management and event handling library - udev quirks
ii  libinput10:amd64                           1.12.6-1                                           amd64        input device management and event handling library - shared library
ii  xserver-xorg-input-libinput                0.28.2-2                                           amd64        X.Org X server -- libinput input driver
$ dpkg -l | grep synaptics
ii  xserver-xorg-input-synaptics               1.9.1-1ubuntu1                                     amd64        Synaptics TouchPad driver for X.Org server
$ xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=13   [slave  pointer  (2)]
⎜   ↳ Logitech USB Optical Mouse                id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
$ 
1
  • Update: In actual use, however, I found that the syndaemon could not catch all possible false clicks onto the touchpad, with many pauses between typing, even if not using the trackpad (I tend to rest my palms directly upon the touchpad which is a habit that is hard to break). Thus I have resorted to the workaround at askubuntu.com/a/1135765/340383 for now. – bgoodr Jun 16 '19 at 13:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.