0

I'm developing a portal and the main aim for this portal is for all my colleagues (whose machines are connected to the same network) to access the portal.

I have tried to reinstall my apache server and it still gives me the same error. I'm using Ubuntu 16.04

I have limited knowledge when it comes to networks and any help will be really great.

This is the supposed output when another machine typed the ip address of my machine

I installed virtualbox and tried to test the problem using that. When I open the chrome and firefox in virtualbox I get these messages:

Firefox:

Unable to connect

Firefox can’t establish a connection to the server at xxx.xxx.xx.240.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer’s network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.
Chrome:

This site can't be reached
xxx.xxx.xx.240 is unreachable
ERR_ADDRESS_UNREACHABLE

I even tried to acess my portal using a machine that has windows as its os it it gives me this error:

Chrome on windows:

This site can't be reached
xxx.xxx.xx.240 took too long to respond
ERR_CONNECTION_TIMED_OUT

This is the most recent error logs in my apache

[Wed Jun 12 07:35:05.832875 2019] [mpm_prefork:notice] [pid 1967] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Wed Jun 12 07:35:05.832891 2019] [core:notice] [pid 1967] AH00094: Command line: '/usr/sbin/apache2'
[Wed Jun 12 15:20:14.048524 2019] [mpm_prefork:notice] [pid 1967] AH00169: caught SIGTERM, shutting down
[Wed Jun 12 15:31:50.238257 2019] [mpm_prefork:notice] [pid 2707] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Wed Jun 12 15:31:50.280681 2019] [core:notice] [pid 2707] AH00094: Command line: '/usr/sbin/apache2'
  • no information, no question? – cmak.fr Jun 7 at 7:23
  • You've given statements, but I too can't find an question, just reference to unspecified error. For most help it should be clear to us, exact command used plus error message. – guiverc Jun 7 at 7:34
  • I just edited my question sorry about that – Francis Kane Jun 7 at 8:17
  • Does it works with the ip address instead of the host name? - Can you ping the ip address of the server from the client? And with the host name? - If no to the previous question, are they on the same network (cf. addresses and mask) and physically reachable (e.g connected to the same router, for example) - Please check also that your VM can be reached from "outside", in the virtual box parameters (don't remember how, but that's something related to the networking setup on Virtual box in itself. Do you have any firewall on the server? – Michael Hooreman Jun 7 at 8:24
  • A:I get the same errors unfortunately A:Yes I can ping my machine through another machine. I can even ping my machine through my virtualbox A:Yes they are not the same network which is .60 (all of our machines here in the office are connected to the same network) A:I don't know if this is the right answer but I tried to ping my VM using a machine used by may colleague and it works A:I don't really have an idea if a firewall exists in our server. but I can access our old portal (w/c is also connected in the same network) without any fuss – Francis Kane Jun 7 at 9:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.